This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Bruno Kos 8 months ago.

Assigned support staff: Bruno Kos.

Author Posts
February 6, 2019 at 12:20 pm

ericC-28

Hello

My website is very slow with wpml. I did some test with and without wpml and we can see I hav some problem with WPML.

Tests with GPmetrix in my preproduction website : hidden link (Captures)

How can I improve the performance ?

Thanks for your help
Eric

February 7, 2019 at 8:13 am #3168880

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Speed optimization is a process itself and depends on multiple parameters, each of which requires tweaking, such as servers and hosting used, caching mechanisms, plugins and themes used and most of this is outside of the scope of our support.

However, I believe that these can also give you some useful info:
https://wpml.org/2012/01/can-your-site-run-faster/
hidden link

Also find some useful info on this topic:
https://wpml.org/forums/topic/how-to-optimize-wpml-performance/

Regards,
Bruno Kos

February 7, 2019 at 12:46 pm #3170225

ericC-28

Hello,
Thanks for your answer, Since I discovered this problem, I tried lot of tips and read lot of articles but nothing works.
And after lot of tests I discovered I have the problem only when wpml is activated.
So is it possible to fix this problem with a real help ?
Thanks
Eric

February 7, 2019 at 1:22 pm #3170384

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

WPML is active at the moment and you are using different domains per language, correct? Has all of this been set properly?
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Please see this thread and and also some advice given by Vincenzo (advice 2) and 3))
https://wpml.org/forums/topic/slow-performance-and-issue-with-different-domain-per-language/#post-2880792

Also, nothing works if you try any of this?
https://wpml.org/faq/prevent-performance-issues-with-wpml/

Is the speed issue happening if you tried different URL formats and not using domain per language option (don't test this without a full site backup if possible)?

I've logged in into the site, but what I can see is quite limited, I don' see any of the WPML settings apart from Media Translation.

Regards,
Bruno Kos

February 8, 2019 at 4:30 pm #3176183

ericC-28

Hi,
Thanks for your answer
I test the different link and methods and I still have the same problem.
I tied also different URL formats and mu site is slow 🙁
I changed the status of your account so you can go to our site and test to understand the problem. It's a staging website so no problem we can broke this version 😉
Thanks for your help
Eric

February 11, 2019 at 1:54 pm #3183172

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I am getting the following message:

ERROR: The password you entered for the username wpml is incorrect.

Can you tell me if you changed this in the meanwhile?

I am trying to login into hidden link.

Regards,
Bruno Kos

February 11, 2019 at 2:06 pm #3183246

ericC-28

Hello

I updated you password, and it's work now.

Thanks for your help
Best
Eric

February 11, 2019 at 2:31 pm #3183437

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Eric,

I've logged in into the site, but what I can see is quite limited, I don't see any of the WPML settings apart from Media Translation.

Is wpml user with administrator privileges?

Regards,
Bruno Kos

February 11, 2019 at 2:33 pm #3183481

ericC-28

Bruno,

Sorry, I restored this morning a version from production without the admin privilege. I changed that so you have all rights on your staging version
Thanks for your help
Eric

February 11, 2019 at 3:01 pm #3183652

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Do you mind if I use this instead:
hidden link

It seems like that GTmetrix is crowded - see the image. However, without changing anything (apart from upgrading WPML plugins), load time seems to be almost exact as on GTmetrix but without WPML being active. And even in practice (when opening the site), I don't have the impression that loading time takes 15 seconds (as With WPML.png shows), not even close to this.

ON Pingdom, you can also choose you preferred testing server location.

As for direct results, page size of 2.7 MB should be definitely less. And if you check "Content size by content type", images and CSS account for almost 80% of that load.

So I am not totally sure if this is WPML related.

Regards,
Bruno Kos

The topic ‘[Closed] My website is very slow with wpml’ is closed to new replies.