This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by peterF-14 12 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 22, 2018 at 9:17 am

peterF-14

I am trying to: Update Welsh home page

Link to a page where the issue can be seen: hidden link

I expected to see:When I update the page I expect to see the latest changes

Instead, I got: A Welsh page that now has content from the English page.

October 22, 2018 at 4:39 pm #2838987

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can understand, there's a synchronization happening between your original-language page and the translated page.

Please follow the steps below:

1. While you are still in the WordPress dashboard, go to the top and change the language flag to Welsh so that you can access the Welsh dashboard
2. Now go to Pages > look for the name of the homepage, hover over the title of that page and under it click the first "Edit" text link. This should take you to the WordPress edit page
3. Now the normal WordPress editor should open (you might see a notification window telling you "Warning: You are trying to edit a translation using the standard WordPress editor but your site is configured to use the WPML Translation Editor." > this will show if you are using the Classic Translation Editor so if this shows up, click on the "Edit anyway" button)
4. Now on the right side of the screen, at the top, you will see a section called "Language" that has a blue box displaying this information "This document is a duplicate of "page-name" page and it is maintained by WPML. WPML will no longer synchronize this page with the original content." (I am attaching a screenshot of this section, too)
5. Click "Translate independently", wait for the page to refresh and you might see again the "Edit anyway" window so click that button one more time

Now the content should not get overwritten anymore.

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai

October 23, 2018 at 8:34 am #2841460

peterF-14

Hi Mihai, Thanks for your help. I've followed your steps but I'm not getting the same pop-ups or Translate independently sections.
After making sure the Welsh flag is at the top of Dashboard (Welsh version) I go to Pages > Homepage > Edit. I get the edit area however no pop-ups or blue language boxes. Please see attached my language box atfter following your instructions.

I've also added a screenshot of the multilingual content setup incase this is the issue as it's suggesting panel-data is copied but I'm not sure why I would want to copy them.

Thanks again,
Anthony

October 23, 2018 at 8:48 am #2841585

peterF-14

Just to add to my above response, I've just tried to edit the English home page. All looked ok but when I went to the Welsh version it had already been translated to English despite having made NO changes to this page.

Seems something is very wrong and just hope this can be resolved quickly as we really need to made changes.

Thanks again for your help Mihai

October 24, 2018 at 10:44 am #2845847

peterF-14

Hi Mihai, Any news on a fix to this? We really need to make changes to the home page but can't without a solution. Can you please update me on any progress or suggestions to resolve this?

Many thanks and appreciate your help,
Anthony

October 24, 2018 at 1:23 pm #2846435

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for all the extra information.

I spent some time on your site's backend and there are a few things that I want us to do in order to isolate the issue even more.

❌ Important: please make a backup of your site (files & database) before following the steps ❌

STEP 1:

Can you please update all the WPML plugins then follow the same steps that were reproducing the issue and let me know if the issue still happens.

If it still happens:

STEP 2:

Go to SG Optimizer > SuperCacher config > Purge the cache + disable Dynamic Caching. After doing this, also disable the "SG Optimizer" plugin and retry the steps to reproduce the issue and let me know if the issue still happens.

STEP 3:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue as there might be some part of the theme's code that's causing that

Please let me know how it goes and what you were able to find.

I will be waiting for your response.

Kind regards,
Mihai

October 24, 2018 at 2:14 pm #2846796

peterF-14

Hi Mihai, Thanks, I've followed your steps and it seems the SiteOrigin Editor is causing the issue.

I'll contact them and let you know what they find.

Thanks,
Anthony

October 24, 2018 at 3:58 pm #2847195

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Anthony.

I'm very glad to hear that you found out what was causing the issue.

Let me know what you will be able to find after you talk with the plugin developers.

Kind regards,
Mihai

October 24, 2018 at 5:22 pm #2847374

peterF-14

Hi Mihai, The issue was down to the Multilingual Content setup section. I posted a picture of it above. The panels_data needs to be set to translate for it to work with the SiteOrigin Editor.

Hope this can help others in the future not have the same trouble.

Thanks again for your help Mihai

October 25, 2018 at 12:53 pm #2849857

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Anthony.

It is great to hear that you managed to solve the issue.

Your input will be highly appreciated by other people who will go through the same situation.

Thank you for sharing it!

Can you also mark this ticket as resolved?

Kind regards,
Mihai

October 25, 2018 at 12:57 pm #2849861

peterF-14

My issue is resolved now. Thank you!