This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.84 hours from now. Thank you for your understanding.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 3 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
July 3, 2019 at 11:24 am #4135395

victoriav-3

I am trying to:

Link to a page where the issue can be seen:

I expected to see: the menu as set up under appearance menus to show in chinese translated pages

Instead, I got: just the translator drop down

July 3, 2019 at 12:02 pm #4136019

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2. Could you please make sure you have followed below doc to translate menus in chinese language:
https://wpml.org/documentation/getting-started-guide/translating-menus/

3. Please delete all sorts of caches on your site / server cache if any / plugin cache / CDN cache (if any), clear browser cache and then see if it resolves the issue afterwards.

4. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

July 3, 2019 at 12:18 pm #4136151
victoriav-3

Hi Norman,
I have created another problem - I have switch my default language to Chinese, thinking it would set the website to Chinese first with the option to switch to English, however in doing so my WPML links in WordPress is now all in Chinese, I can't reset it back to English and I am unable to find the Debug info as it's all in chinese...

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/how-to-change-site-admin-language/

July 3, 2019 at 12:54 pm #4136537

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To handle new issue, I have created a new ticket since this is a separate issue. Here is the link to the new ticket:
https://wpml.org/forums/topic/how-to-change-site-admin-language/

Thank you for your cooperation and patience.

The topic ‘[Closed] nav bar menu in translated mode chinese not showing’ is closed to new replies.