This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Andreas W. 1 year, 2 months ago.

Assigned support staff: Andreas W..

Author Posts
December 27, 2018 at 7:39 pm #3038382

hooiC

Hi,

Trying to navigate to different languages always results in English being displayed. Have tried directories and sub-domains - same result.

Kind regards,

- Stuart

December 27, 2018 at 9:12 pm #3038537

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

There can be various reasons for the issue that you are experiencing. Could you please confirm your config at WPML -> Languages -> Hide languages.

Also it might be that the option for Browser language redirect is activated at WPML -> Languages -> Browser language redirect.

Another case is that default language content might get displayed as a translation for the second language is not available. You can find this option at WPML -> Settings -> Post Types Translation -> Translatable - use translation if available or fallback to default language.

If not any of these options solved your issue it might be faster if we would take a quick look at your site ourselves.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Please also make sure that your theme and any plugin is up-to date.

Also could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Best regards
Andreas

December 28, 2018 at 11:05 am #3039804

hooiC

Hi!

Thank you for contacting WPML Support.

There can be various reasons for the issue that you are experiencing. Could you please confirm your config at WPML -> Languages -> Hide languages. We are currently not hiding any languages. See hide languages section.

-->> Checked

Also it might be that the option for Browser language redirect is activated at WPML -> Languages -> Browser language redirect. Currently, we have checked against “Disable browser language redirect”

-->> Checked

Another case is that default language content might get displayed as a translation for the second language is not available. You can find this option at WPML -> Settings -> Post Types Translation -> Translatable - use translation if available or fallback to default language. Almost all checked against “translatable-only show translated items”

-->> Checked

If not any of these options solved your issue it might be faster if we would take a quick look at your site ourselves.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I'll need to temporarily install a plugin called "Duplicator" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

-->> I don't see the login details section - please activate. We are not running FTP. The duplicator plugin is installed.

Please also make sure that your theme and any plugin is up-to date.

Also could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

-->>> This is done.

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Best regards

December 28, 2018 at 2:11 pm #3040394

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

I am sorry about the inconvenience and I am sending the request for access again.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

December 28, 2018 at 5:01 pm #3040902

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I checked your store pages and other pages that are already translated and all the URLs were correct. Some contents are still missing translations.

The fact that your frontpage hidden link is not changing the URL when selecting a different language on the WPML language switcher is caused by the fact that this page and others are not translated yet. (Please see screenshot attached).

I would kindly like to ask you translate all pages and let me know if the issue persists.

Kind regards
Andreas

January 2, 2019 at 10:45 am #3048612

hooiC

Hi,

Thankyou for your reply.

When I try and navigate to edit pages, I get a 500 error cannot handle the request.

Kind regards,

- Stuart

January 2, 2019 at 2:31 pm #3049523

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

After checking the information on WPML -> Support on your admin panel your actual memory limit is still 40M. If you completed the prior mentioned steps for setting the limit it might be the case that your hosting provider set up a block to change those settings.

Please contact your hosting provider to make sure that your WP Memory Limit is set to 256M.

Further, if this did not solve the issue, it might be that the 500 Error is caused by a corrupted .htaccess-file. You could simple try a workaround by renaming your old .htaccess-file through FTP access. Next go to the Settings -> Permalinks page in the WordPress admin area and click the save button. This will generate a new .htaccess-file with proper rewrite rules to avoid any 404 errors.

If this still will not solve the problem please deactivate any WordPress Plugin and see if the issue persist.

At last please provide us your WP Debug information. You can find a documentation with instructions right here:

https://wpml.org/documentation/support/debugging-wpml/

Kind regards,
Andreas

January 2, 2019 at 4:54 pm #3049947

hooiC

Thanks Andreas.

I had a typo in the wp-config. In the end I made PHP memory 512M and wordpress 256M. We are now trying to duplicate all the translations to get the url redirect working.

Kind regards,

- Stuart

January 2, 2019 at 11:44 pm #3050874

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

I just took a look at your website and I realized that the URLs are working fine now. I only realized that there is a problem about your blog (see screenshot attached). Please let me know if this issue also persist when WPML is disabled to clarify if this problem might be related to one of our plugins.

Do not hesitate to contact us for any further assistance.

Kind regards
Andreas

January 3, 2019 at 9:57 am #3051844

hooiC

Hi Andreas
thank you for spotting the blog page issue. i deactivated the WPML Multilingual CMS plugin. refreshed the blog page on webdev.mylotus.com and the error is still there. then i deactivated all the wpml plugins and refreshed the blog page and we still have the error 404 issue. Please advice what else we can do to fix this issue. thank you very much. Hooi Cheeseman

January 3, 2019 at 3:27 pm #3053388

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

As long the errors do persist while WPML and its add-ons are deactivated we can clarify that this issue is not related to WPML.

The errors do refer to .php-files inside the wp-includes folder which is part of the WordPress Core. I would kindly advise you to reach out to WordPress support at

https://wordpress.org/support/

I would also advise you to disable any plugin and if the issue disappears start reactivating plugins until the issue appears again. This way you could determine which plugin is causing the problem. Same to the theme, try with one of the default WordPress themes to make sure if the issue is related to your current theme or not. You might make those tests on a local environment to not harm your current site.

hidden link

I also realized that you got an error related to the WP Affiliates plugin. You might contact their support as well to solve this issue.

Please do not hesitate to contact us again if you need further assistance with WPML.

Kind regards
Andreas

January 3, 2019 at 6:06 pm #3054256

hooiC

Hi Andreas
thank you for your advice. i have tried deactivating the plugins. all the notices disappeared when i deactivated woocommerce plugin alone but error 404 remains on the blog page.

but we want to check with you is how can we change our existing blog to wpml permalink format?

January 3, 2019 at 10:59 pm #3054759

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I checked the URLs of your Blog page for English and Irish and they look perfect. The 404 on the Irish Blog page must be a result of the fact that you not have any Irish post translated yet.

Please start translating the blogs into Irish and let me know if this solved the 404 error.

Further, please follow my prior advises to solve those additional PHP errors with the respective support channels.

Kind regard
Andreas

January 4, 2019 at 9:28 am #3055562

hooiC

Hi Andreas
Thank you for your advice. translated Ireland blog posts . error 404 still remain on both uk and ireland for the blog page. we hope to look at the php issue later to see if this will resolve this error 404 issue.
We also went to wordpress-settings-permalink- and click on save changes after the translation above. again it has not fixed the issue.

January 4, 2019 at 6:01 pm #3057486

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I can see that URLs for single posts from your blog are working but the wp-query error is relating to a database issue the blog page.

As you explained the issue persists when WPML is deactivated which for it must be related to a different plugin or the theme.

You might try to see if the issue persists with a default theme and also try to disable any plugin and in case this issue is gone you might reactivate the plugins one by one to indicate which of the causes the issue.

This troubleshoot can help you do determine whose support team might be able to help on this matter.

We sadly can not further assist you on as the issue is not related to WPML but please do not hesitate to contact us about any prior issues you might experience with WPML.

Kind regards
Andreas