Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by hooiC 11 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
February 15, 2019 at 11:07 pm #3206818

hooiC

I am trying to: currently, i am translating several secondary language sites(German,French and Spanish) on live sites. I have hidden them from public view so they don't appear on the language switcher. However, I have allowed myself to see the languages on the switcher. the strange thing is sometime i can navigate to German but other times during the day, I was not able to. It defaulted to English. Then, I made German live for public view and this time I could navigate to German. then I hid the language again. this time i tried navigating to Spanish site and it defaulted back to English! so I am not sure if hiding several languages caused this issue or something else. please advise.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

February 17, 2019 at 9:28 pm #3209637

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

In WPML -> Languages -> Language switcher options, which one of the following options is selected on your site?
A. Skip language
B. Link to home of language for missing translations

Do you have the homepage of all the languages translated?

Are WPML and its add-ons updated to their latest versions on your site?

Could you please share your Debug information with me?
You can read the detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Thanks,
Itamar.

February 18, 2019 at 9:38 am #3210812

hooiC

Hi Itamar, In WPML -> Languages -> Language switcher options, this option was selected: Link to home of language for missing translations.
Do you have the homepage of all the languages translated? - what do you mean by homepage? all pages/posts with status: published have been translated for English, Ireland, German, france, Spanish. this morning I can navigate to German site but not able to navigate to Spanish after selecting Spanish on hte language switcher. for spanish, there are private pages(not published) which i did not translate. does this matter?

February 19, 2019 at 11:09 am #3216250

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi there and sorry for the late reply.

By 'homepage' I mean the page that shows for the main domain. In your site's, for example, here.
English: hidden link
Irish: hidden link
So do you have the homepage of Spanish, German, French translated?

Furthermore, in WPML -> Languages -> Language URL format, you have selected the option 'A different domain per language'.
Do you have a valid domain for each one of your languages?

Moreover, I can see that WPML and its add-ons are updated to their latest versions. But WordPress itself is not updated.
Could you please update WordPress to its latest version and see if the issue persists?

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

If the above suggestions do not help, then please share with me the access to your site so I can better see and check the issue. For this, I'm enabling a private message for the next reply.

Thanks,
Itamar.

February 19, 2019 at 12:22 pm #3216508

hooiC

Hi Itamar,
So do you have the homepage of Spanish, German, French translated? yes, they are all translated.
Do you have a valid domain for each one of your languages? -yes, they are all valid subdomain for each language.
wordpress plugin - i am not allowed to update but the IT officer will update over the weekend. by the way, the live site is in a load balance environment. would it affect this navigation issue?
i think once wordpress is upgraded over the weekend, i will check and see if this navigation issue is resolved. if not, i i will share with you signing credentials to give you access. thank you

February 20, 2019 at 11:34 am #3221325

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

OK, I'll wait for your reply.

I'm enabling a private message again.

Regards,
Itamar.

March 7, 2019 at 11:10 am #3283814

hooiC

My issue is resolved now. Thank you!