This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 2 weeks, 4 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 19, 2019 at 12:51 am #4600407

ralphG-7

I am trying to:
Migrate from polylang to wpml, the website have only 2 languages : French and English (as main language). Links seems to work great, but then after activating media translation, images are not synced together.

Link to a page where the issue can be seen:
Don't have link sorry. It was on a staging site that I already reset, now I have done the migration again but without activating media translation this time.

I expected to see:
Images appearing in the correct language on the site.

Instead, I got:
English images appearing on french pages... When I open media translation tool, both french and english image appears, and are marked as waiting translation.

Another problem, is that I use smart slider on the homepage (at the beginning) but I don't find where to update the shortcode when I try to translate the homepage. So english slider appears on french & english homepage.

I need to migrate from polylang to wpml since I need the toolset plugins.
Links work correctly, and text is translated correctly too.
If it can help, I use elementor (free) as pagebuilder.

September 20, 2019 at 2:55 pm #4613093

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Create a full backup of the site
- Go to WPML -> Settings -> Media Translation -> Select all options -> Click on Start button.
- Go to WPML -> Support -> Troubleshooting link -> Apply the troubleshooting steps highlighted in the attached image.

Could you tell me the results of the steps above?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 20, 2019 at 7:13 pm #4614203

ralphG-7

Hi,
Thanks for the reply,
I followed step 1 and 2 but the problem was there again.

So I restored the backup and do step 1 again.
And everything works fine now, I think I did not do the media translation setup at the right time during the first installation.

I will increase PHP memory limit again too.

September 23, 2019 at 9:16 am #4621905

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Could you confirm that the issue is solved?

Regards,
Carlos

September 23, 2019 at 2:20 pm #4624921

ralphG-7

Thanks, the first problem is solved, but the second one is not yet :

I use smart slider on the homepage (at the top) but when I try to translate the page using wpml, I don't find where to modify it, I already have 2 slider (french and english).

The slider is added to the page with a shortcode ,I don't know if there is something to change in the settings of wpml to change shortcode according to language.

September 23, 2019 at 2:56 pm #4625253

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

In this case I kindly ask you to visit this ticket and in the summary you will find the steps to follow in order to use Smart Slider with different languages: https://wpml.org/forums/topic/translation-smart-slider-3/

Regards,
Carlos

September 27, 2019 at 7:45 pm #4656593

ralphG-7

Thanks, I will this article.

September 30, 2019 at 8:40 am #4663011

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Could you confirm that the issue is solved?

Regards,
Carlos