Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Diego Pereira 1 year, 4 months ago.

Assigned support staff: Diego Pereira.

Author Posts
August 6, 2018 at 2:12 pm #2616125

adoneB

Tell us what you are trying to do?

I am trying to get started using WPML but the task looks overwhelming to me. I find the learning curve very steep.

I am now in the phase that I am fighting trying to display the language switcher. I added it to the main menu and to the footer but none of them show up.

can you help in this please?

August 6, 2018 at 5:17 pm #2616914

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @adoneb, welcome to the WPML support Forum! You can count on us if you need any help 🙂

In order for the menu language switcher to work, there must already be a menu configured in Appearance> Menus.

It looks like the footer language switcher is configured correctly.

It seems that you need to create more than one language for your website. Since there is apparently only one language (Spanish), the language switcher is not displayed because there is no other language available.

Here is the link of our documentation: https://wpml.org/documentation/

If you need more help just let me know.

All the best,
Diego

August 6, 2018 at 7:27 pm #2617168

adoneB

Hola Diego, gracias por tu respuesta.

Regarding the following that you say:

"Since there is apparently only one language (Spanish), the language switcher is not displayed because there is no other language available."

Please see the attachment, the site is in English and I am defining a second language (Spanish) so I don't get your point

Second:
"It looks like the footer language switcher is configured correctly."

Please see the second attachment, no switch in my footer

Third:
"In order for the menu language switcher to work, there must already be a menu configured in Appearance> Menus."

Indeed I have a menu called "menu" defined under my menus
(See third attachment)

Please let me know what's going on
Adone

August 6, 2018 at 7:47 pm #2617258

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Could you please send us access to your WordPress dashboard (website URL, login and password)? I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” or "All-in-one WP Migration" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please let me know if this is ok for you.

Regards,
Diego

August 7, 2018 at 12:11 pm #2620155

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks! Apparently, the languages were correctly configured, but the translations have not yet been created (see screenshot).

I created a translation for the homepage and now the language switcher appears in the menu and in the footer: hidden link - You need to create on the "+" icon to create a new translation for each page.

If you need more help just let me know.

Regards,
Diego

August 7, 2018 at 8:22 pm #2621770

adoneB

Hola
I appreciate so much your help and I am happy that something start working however I'm still in the darkness.

In order to understand how this thing works I am now trying to experiment and trying to translate an article of the blog, specifically this one:
hidden link

I went to the post and added a translation (not a real translation though, only the title leaving the rest untouched, this is just for learning). After saving and closing I navigated to this post but can't see the language switcher.

I definitely need a tutorial, it appears it's too difficult for me :((

August 8, 2018 at 12:25 pm #2624510

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Apparently you did not fill in all the translation fields. That's why it has not been published. These are the necessary steps:
- Go to Posts > All Posts
- Click on the "+" or the "Pencil" icon of the post you want to translate
- Fill all fields with the translations. You can click on "Copy all fields from original" button if you want, then edit each field if needed
- Check the "Translation is complete" checkbox on all fields. The translation must have the "100% translated" status in order to be published.
- Save

I did a test on this post and everything worked correctly (see screenshots). You can check it here: hidden link

If you need more help just let me know. I can also record a video with these steps 🙂

Regards,
Diego