This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by ahmedM-19 5 months, 1 week ago.

Assigned support staff: Dennis.

Author Posts
March 3, 2019 at 3:36 pm #3266400

ahmedM-19

Tell us what you are trying to do? try to activate plugin but failed

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site? farmexco.com

March 4, 2019 at 8:44 am #3267498

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Have you tried unregistering WPML, generate a new key and registering WPML again? If not, please follow these steps:

- Click on the Unregister WPML button at the Plugins > Add new > Commercial page.
- Go to WPML.org and at https://wpml.org/account/sites/ . Delete the site key for hidden link

- Create a new one and enter you site url: hidden link
- Take note of the new key.
- Register plugin using your new key.

Does it help?

Also, could you please share your Debug information with me?

You can read the detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support

The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Kind regards,
Dennis

March 4, 2019 at 9:38 am #3267751

ahmedM-19

Hello Dennis,

I followed your steps but nothing changed, check this please: hidden link
I am not able to activate the plugins, check this please: hidden link
hidden link, hidden link
When activate Multilingual CMS, this messages showed up: hidden link

Waiting for your feedback

Thanks
Dodd

March 4, 2019 at 10:03 am #3267895

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

Edit wp-config.php and insert the following lines:

/*enable debugging*/
define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false);

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Then try to activate WPML CMS plugin.

Locate the debug log in: /wp-content/debug.log using FTP, then edit/view the content of the file. It would be great if you can share with me the debug.log content using pastebin.com

Kind regards,
Dennis

March 24, 2019 at 10:49 am #3448105

ahmedM-19

I still need assistance for farmexco.com
WPML Multilingual CMS not working so I can not send debug information.

Looking for your support.
Thanks

March 24, 2019 at 10:57 am #3448117

ahmedM-19

I followed your steps and added to wp-config but found no debug.log

March 25, 2019 at 1:22 am #3449227

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your updates.

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

March 26, 2019 at 4:02 am #3459111

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

It seems that you haven't configured WPML before on this site, right?. If this is the case, could you please update your WPML plugin? You can download an updated copy of WPML plugin at your wpml.org account.

https://wpml.org/account/downloads/

Then please follow these steps:

-Backup your site completely.
-delete WPML Plugin
-upload and install the updated WPML plugin
-activate WPML.
-configure WPML
-update WPML addon plugins at Plugins > Add new > Commercial tab

Please let me know how it goes.

Kind regards,
Dennis

March 26, 2019 at 12:42 pm #3462375

ahmedM-19

Hi Dennis,

I followed your steps:

-Backup website completely.
-delete WPML Plugin
-download the updated plugins
-try to upload and install it

Failed to install wpml-translation-management.2.8.3 & sitepress-multilingual-cms.4.2.4.1

Please let me what's going on.

Kind regards,
Dodd

March 27, 2019 at 3:28 am #3467439

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your updates.

To get a better look of the issue I would like to request for temporary FTP access. I will enable the access information box for and will set your next reply as private.

Thank you.

Kind regards,
Dennis

March 28, 2019 at 1:18 am #3476373

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Unfortunately, for some reason, the FTP credentials does not work on my end. I'm getting 'Access denied' error. Could you please check?

Thank you.

Kind regards,
Dennis

April 1, 2019 at 1:54 am #3502901

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for providing us with the updated FTP login credentials.

I noticed that you don't have the proper directory and file permissions. Could you please set the appropriate file permission for files and directories?

You might find this guide helpful:

hidden link

Once done. please follow the steps previously provided.

https://wpml.org/forums/topic/need-to-activate-the-plugin/#post-3459111

Please let me know how it goes.

Kind regards,
Dennis

April 2, 2019 at 4:19 am #3513787

ahmedM-19

Hi Dennis,

What did you do with directories !!!! Root folders changed.
Why did you ask for ftp details while you're telling me now to do again what you told me one week ago.

Please clarify.
Thank you

April 2, 2019 at 4:41 am #3513923

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

I have asked for the FTP access because I am suspecting that you might have incorrect directory permissions. So, basically after logging in to FTP I just checked it and informed you on what I have noticed.

With the incorrect directory permission, it could cause the plugin installation to fail which could cause the error you mentioned last week : "Failed to install wpml-translation-management.2.8.3 & sitepress-multilingual-cms.4.2.4.1".That is, to test if you can now re-install WPML using the method previously provided after you are be able to correctly configure the directory permissions for your site.

Kind regards,
Dennis

April 9, 2019 at 4:30 am #3563085

ahmedM-19

My issue is not resolved.