This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 2 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
August 6, 2019 at 11:14 pm #4350769

liS

I have been trying to install WPML plugin on the website over 6 times yesterday, but the same problem happened again. Please find the warning message as following and attachment:

let me give your the backend user name and password:
**CREDENTIALS REMOVED FOR SECURITY REASONS**

It is new set up website, no need to make a copy. So please simply install WPML and let me know:
WPML default language: English (first language)
WPML second language : Chinese simplified
No other languages are needed when you go through the steps.
_____________________________________

Plugins Add New
There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you.

We have detected a problem with some tables in the database. Please contact WPML support to get this fixed.

Table 'seosolut_philippinessources.site.wp_icl_strings' doesn't exist
Array
(
[language] => en
[context] => WP
[gettext_context] =>
[domain_name_context_md5] => 5ff0887b4c486c0329311e8d30610d58
[name] => Blog Title
[value] => Philippines Sources
[status] => 0
[translation_priority] => optional
[allow_empty_value] =>
)
Hide this notice.Dismiss this notice.
Your WPML installation may cause problems with Gutenberg editor
You are using WPML Translation Management without String Translation. Some of the translations may not work this way. Please download and install WPML String Translation before you translate the content from Gutenberg editor.

WPML String Translation (Activate)

August 7, 2019 at 12:41 am #4350933

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

As far I can see the issue is caused due to the fact that there is not any language set on WPML and the language option is not working.

Further, I realized that zour whole WordPress Install was acting odd and I was not able to add any themes. I reinstalled WordPress and added the TwentyNineteen Theme.

Even diabling the plugins did not solve the issue and there is a odd thing about that WPML is displayed in last version but the link to its documentation shows version 3.9

Further, your WPML is not registered yet. Please delete all WPML plugins and go to the following links to download the latest versions. Then install and activate them again and leave any additional plugin disabled in the meantime.

https://wpml.org/account/downloads/

Now, go to the following link and register your URL in order to receive a WPML site key. This key you will then enter at Plugins -> Add new -> Commercial -> Register WPML.

I hope this will solve the issue. Make sure to run the complete setup wiyyard for WPML by setting the languages and language switchers.

Kind regards
Andreas

August 7, 2019 at 2:23 am #4351297

liS

Andreas :
Thanks for your reply and help.
I followed your advice and registered and filled in the WPML key for hidden link.
I can not understand why there are no pages created on the page list at the backend after I activated the plugin woocommerce, normally the cart, shop, my account, register pages will automatically fallen on the backend pages. Can you help me check and fix it?
I have limited knowledge to WP database, but all problem aroused from WPML. Hopefully you can help me out. If you have any questions, please be free to let me know.
I am working in Shanghai China now.

August 7, 2019 at 4:48 am #4351993

liS

Andreas :
I stopped over philippinessources.site and went to work on another site, hidden link, the same strange problem happened again, after installing WPML plugin, all pages disappear at backend. It is impossible to continue to translate the pages. PLease pay attention to my issue and may report it to your technical staff. Looking forward to a quick solution. thank you, have a nice day !
Please find my attachment of the screen shots to show you the same issue happened at another site.

August 7, 2019 at 4:02 pm #4356665

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Are both sites using the same hosting? It might be that the hosting company is blocking some kind of resource that WPML needs to complete its setup. Could you please contact your hosting and ask them to check the server error.log?

Further, I would like to debug your site but I need access to the server in order to do that.

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 7, 2019 at 11:59 pm #4358619

liS

Andreas:
Thanks for your proposal.
I will need some time to copy the website contents and sql before I send you password to access to the server.
It happens there is a new site to be published, you will be able to use that one as a test. The site is newly set up with only sample content. Let me contact you later.

August 8, 2019 at 4:13 pm #4364705

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I understand. Please reach out again as soon you got access ready. Alternatively, you also could provide a download link for a Duplicator package.

hidden link

Kind regards
Andreas

August 9, 2019 at 2:58 am #4366927

liS

Andreas :
thanks for your nice help.
I have found a solution to set up the WMPL already. It looks normal now. You may close the ticket. thanks.

August 10, 2019 at 12:22 am #4373275

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for letting me know.

I am glad to here that the issue got solved. Do not hesitate to contact us if you need any further assistance.

Kind regards
Andreas