Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Alfredo 6 years, 1 month ago.

Assigned support staff: Shane.

Author Posts
September 3, 2015 at 8:58 am #696586

Alfredo

I am trying to: After multilingual last update, when i modify a product and save it I have this error code lines:
Notice: Undefined index: products_sync_order in /home/cleanlab/public_html/sansonestore.com/wp-content/plugins/woocommerce-multilingual/inc/products.class.php on line 2992

Warning: Cannot modify header information - headers already sent by (output started at /home/cleanlab/public_html/sansonestore.com/wp-content/plugins/woocommerce-multilingual/inc/products.class.php:2992) in /home/cleanlab/public_html/sansonestore.com/wp-includes/pluggable.php on line 1207

The product modifies are saved, but I have to solve this iusse.

URL of (my) website where problem appears:

I expected to see:

Instead, I got:

September 3, 2015 at 7:48 pm #697290

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Alfredo,

Thanks for contacting our support forum.

I must apologize for the delay in response.

Could you try to disable your other plugins temporarily so that we can ensure that you are not experiencing a plugin conflict.

Once you have done this please let me know and we can move to the next step.

Thanks

September 5, 2015 at 7:27 am #698291

Alfredo

Hello Shane. I'm late too:) But I 've to work on other iusses of the site and deadline is so closed.
I have made all basic attempts, disabling all plugins and activating one default Wp theme. Nothing I have this error code line when I save a product, both English an Italian (default language).
If you mark as private I could send you a backup via googledrive.
Thanks for your time and Regards,
Alfredo.

September 5, 2015 at 7:32 am #698292

Alfredo

I attach another line code, I think two iusse are linked.
When I switch from En to Ita I have on product page:
products_sync_order in /home/cleanlab/public_html/sansonestore.com/wp-content/plugins/woocommerce-multilingual/woocommerce_wpml.class.php on line 461
I can work cliking on back button of browser, the modifies are saved. But it's clear that something is wrong.:)

September 7, 2015 at 7:08 pm #699258

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Alfredo,

I have marked your next response as private so that I can assist better.

See the fields for attaching the credentials.

Thanks

September 7, 2015 at 7:08 pm #699259

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Alfredo,

I have marked your next response as private so that I can assist better.

See the fields for attaching the credentials.

Thanks

September 7, 2015 at 7:08 pm #699261

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Private fields below.

September 8, 2015 at 6:43 pm #700081

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Alfredo,

Thanks for providing me with the duplicator package.

The problem is that you have the wp_debug enabled so you will be seeing the warning that will generated.

Taking a look at these warnings they don't seem to be anything that should be a cause for alarm.

To disable debugging just go to your wp-config.php filer and look for the line define('WP_DEBUG', true);

Then set true to false.

Let me know if this helps.
Thanks

September 9, 2015 at 8:18 am #700496

Alfredo

Hello Shane.
The iusse seems to be solved.
Thanks for your attention and time.
Regards.
Alfredo.