This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.55 hours from now. Thank you for your understanding.

This topic contains 23 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 6 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 8, 2019 at 11:15 am #3291618

silviov-2

I have added 2 languages ​​to my website France and Spanish, and have also made the necessary pages for it. However, I do not know how I get these French and Spanish pages linked at the top of my Menu.

Could you help me with this.

hidden link

I wil send you the credentials of the backend if you want. Please let me know

March 8, 2019 at 6:37 pm #3294980

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 8, 2019 at 8:03 pm #3295402

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your website and could notice there's still no spanish translation for your homepage as can you see in the attached screenshot, if you try for example:

hidden link
hidden link
hidden link
hidden link

All of the above is working properly, only the spanish translation is returning a 404 not found error, and the reason for that is the fact you still don't have a translation published for it. Please, make sure there's a spanish translation available for your homepage and try the language switcher in your website header again.

Please, let me know if you need any other detail. Have a nice day.

March 8, 2019 at 8:19 pm #3295438

silviov-2

Hi Marcos,

I wrote several Spanish pages today and also the French pages. See for yourself these 2 languages ​​are just on all pages under the French and Spanish flag, but the French and Spanish pages can not be linked to the switcher menu.

I hope you can.

March 11, 2019 at 3:18 pm #3314223

silviov-2

Hi Marcos,

Wil you respond on my last reply on 8 march 8:19 PM

Please check this issue for my...

Kind regards Silvio

March 11, 2019 at 5:18 pm #3314979

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Silvio,

Thank you for the updates and sorry for the bit of waiting here due the weekend. I took a detailed look in your website and could find the reason for such issue, let me explain:

1 - The default language of your website is dutch (nederlands) this way all your posts and pages should be created in this language and then you should add translations for the content created in the default language.

2 - In your current setup you are creating the content independently in the secondary languages (spanish in your case), all the content for the secondary languages needs to be a translation of your default language content, otherwise the language switcher will not link the different translations in your website, in a nutshell this should be the right setup:

2.1 - Create the content in the default language from your WordPress Dashboard > Pages > Add New

2.1 - Add a translation for it in every secondary language you have.

See: https://wpml.org/documentation/getting-started-guide/

3 - For all the existing pages you have created independently in the secondary languages you can link them with the content in default language using the language box in your page editing screen from your WordPress Dashboard > Pages settings. In this case, you can try the following:

3.1 - Click to edit the spanish page that shoould be a translation of your dutch homepage content, in your case it is the page 'Quién es Tajima Europe?'.

3.2 - In the page editing screen link it with the dutch homepage using the language box exactly as describred in the attached screenshots.

Repeat these steps for any spanish page that should be a translation of the dutch pages. Please, let me know if you need any further clarifications regarding the steps above.

Have a nice day.

March 14, 2019 at 4:14 pm #3346833

silviov-2

Hello support team,

I have read the last explanation several times and tried it on the website, but I can't figure it out, I really don't understand what I have to do now to get the menu structure right.

I have manually added the French and Spanish language in the pages by my own written translations. But I assume that I didn't do this for nothing, because I would like to see these pages as written by me on the website.

But I really can't figure it out, which of you can help me personally.

March 14, 2019 at 7:21 pm #3348157

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I performed the steps of my previous reply and could make your spanish page to be a translation of your dutch homepage as you can see at: hidden link. The only thing you should do now is to edit your spanish homepage to adjust the carousel images exactly as you have done with your other homepage translations from your WordPress Dashboard > Pages settings. Please, let me know if you need any additional assistance, have a nice day.

March 15, 2019 at 1:59 pm #3354437

silviov-2

Okay thank you in advance for this support, but I wanted to adjust the carousel slider, but now I see when I want to access the media library from the france and spasnse pages, I suddenly see that these are now empty. But they are available in the Dutch, Englisch and Deutsche pages. So yes now I cannot continue to apply these 2 new languages.

What a difficult pluging this is, and I have paid so much money for it.

What should I do now?

March 15, 2019 at 3:31 pm #3355161

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. It does happen since you added the two additional languages (spanish and french) after the images upload process. In this case, you can make sure all your images are available across the languages with these steps:

1 - In your WordPress Dashboard > WPML > Settings > Media Translation click the start button to make all the uploaded images acrosso languages.

2 - Now you should be able to see the images in the media library for all the languages.

Please, let me know if you need any additional assistance. Have a nice day.

March 15, 2019 at 6:15 pm #3356271

silviov-2

Yes, super, the problem with the media library is indeed solved now. But now I have also added the Spanish and French pages pages in the menu environment. But in the frontend I see that the menu is not correct as soon as I select French or Spanish in the switcher

March 15, 2019 at 6:43 pm #3356499

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. As you have added your spanish and french languages after the initial WPML setup, you also need to make sure you have menu translations for these two additional languages as you can read at: https://wpml.org/documentation/getting-started-guide/translating-menus/. Please, let me know if it helps, have a nice day.

March 16, 2019 at 11:28 am #3360021

silviov-2

Jesus this is all very complicated for me, I am not a web designer. You send me some information with the steps to be followed, but the final result is that it still does not work as it should. And what I say already seems very complicated to me. I had the same problem last time (a year ago), and then it was neatly solved by one of your colleagues, but now I have to do it myself. I can not get out.

I have followed your last steps, but now there are 2 in French and Spanish instead of the others that should be there. Sorry but I am no longer able to solve this myself.

March 18, 2019 at 5:22 pm #3371839

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bit of waiting due the weekend. Actually the menu translation should be pretty straight forward, once you have your page translated, you only need to drag them to the proper menu area and save it. Here are the detailed steps:

1 - In your WordPress Dashboard > Appearance > Menus change to the language you need to setup your menu, spanish and french in your case. See attached image 'screen_customer_49.png'.

2 - Click to add the spanish pages to your spanish menu. See attached image 'screen_customer_50.png'.

3 - Assign your menu items to the proper menu area (primary menu in your case) and save it. See attached image 'screen_customer_51.png'.

Repeat the steps above for all the languages in your website. Please, let me know if you still face issues in following the steps, I am always happy to help, have a nice day.

March 25, 2019 at 1:30 pm #3453963

silviov-2

Hi Marco

Now the right Spanish and France languages ​​are active in the selector. But now I see that the Dutch homepage is in French instead of Dutch. How can I change that.

Kind regards

The topic ‘[Closed] new languages not visible in my flag menu’ is closed to new replies.