This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Noman 2 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
August 4, 2019 at 8:17 pm #4336919

mikaelG-6

I am trying to: The new link to Privacy Policy in Store Front footer is translated to default language in all languages

Link to a page where the issue can be seen: hidden link (this is the translation of my store @ hidden link)

I expected to see: The footer displays "Integritetspolicy" in the footer in english language though it should be "Privacy Policy" which is the correct label in English.

Instead, I got: It should be "Privacy Policy" which is the correct label in English.

I have contacted Store Front developers and they responded that the issue is caused by WPML.

August 5, 2019 at 4:35 am #4337837

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. If you have added "Privacy Policy" text in footer from customizer/Theme Options then you can translate this text by following below doc: https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

August 5, 2019 at 8:31 am #4338997

mikaelG-6

Please read this carefully.

I haven't added anything. Storefront made a change in their latest update where the Privacy Policy is displayed as default in the footer. This text is shown as "Integritetspolicy" on both Swedish (default language) and in English (Secondary language). It should be "Privacy Policy" in English.
This is a built in feature in WordPress and the filter that adds the footer link is using WordPress default code for this. This is all according to Storefront developers. They also said WPML should correct this as the issue is with WPML.

August 5, 2019 at 1:01 pm #4340699

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

August 6, 2019 at 9:10 am #4345641

mikaelG-6

Hi.
I don't give out site access. This is an issue you would easily see if you just visit the URL:s I provided. And there is nothing in String translation that is possible to fix this, as the string "Integritetspolicy" is already translated on all occurrences.
So something is wrong in the way WPML is displaying this phrase in secondary language.

Can you please find another way of testing this without access to my site. There must be others that have the same issue. I don't use any special settings other then the defaults in WPML.

August 7, 2019 at 10:17 am #4353465

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please follow below steps and let me know how it goes?
1. Add Privacy Policy page in default language from Settings >> Privacy as you can see in the attached screenshot.
2. Add translation of Privacy Policy page in secondary language.
3. Add below XML code in WPML >> Settings >> Custom XML Configuration section:

<wpml-config>
    <admin-texts>
        <key name="wp_page_for_privacy_policy" />
    </admin-texts>
</wpml-config>

4. Now you can add Privacy Policy page IDs as translation from WPML >> String Translation as you can see in the attached screenshot.

I hope it will resolve your issue. Could you please check and confirm?

Thank you

August 7, 2019 at 10:51 am #4354009

mikaelG-6

Hi.
I already have privacy policy for both languages set up. Are you another supporter that can't read?
Have you even checked the URL:s provided.

I why is the steps with adding page ID:s even necessary? If the string Privacy Policy is already translated and this is a DEFAULT WordPress string, why isn't these strings and translations applied as they should be?

Your support is getting worse and worse. I will truly start searching for another way to use multilingual WordPress. As I pay MUCH money for this plugin, I think the support should be top notch. And it isn't, the supporters I had to deal with doesn't even seem able to read. Which should be a basic approach when giving support!

It works for now, but I think you really should fix this issue. Because all these customizations to get basic features to work will be a pain to control when they become to many.

August 8, 2019 at 12:06 am #4358661

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Sorry for not being clear about the steps I mentioned above. I am adding all answers and info below your questions here:

1. Why is the steps with adding page IDs even necessary? If the string Privacy Policy is already translated and this is a DEFAULT WordPress string, why isn't these strings and translations applied as they should be?

-- Privacy policy is a new feature in WP and how WordPress is displaying that part can only be handled using string translation. That's why we need to give translated page ID and translate that string manually at moment.

2. Your support is getting worse and worse. I will truly start searching for another way to use multilingual WordPress. As I pay MUCH money for this plugin, I think the support should be top notch. And it isn't, the supporters I had to deal with doesn't even seem able to read.

-- Sorry, I told you all the steps that I followed in my test site while reproducing this issue using storefront theme, so it might be helpful for other users as well in future. I am really sorry if I could not understand your earlier message.

3. It works for now, but I think you really should fix this issue.

-- Glad to see it’s working. XML method is an alternate method of enabling string's translation that’s why I used it.

You can submit your request to improve this feature or part, so our developers can find a better way to handle its translation in future updates: https://wpml.org/suggest-a-new-feature-for-wpml/

Thank you so much for your cooperation and understanding.

The topic ‘[Closed] New link to Privacy Policy in Store Front footer is translated to default langua’ is closed to new replies.