This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by timoB-2 2 weeks, 6 days ago.

Assigned support staff: Bobby.

Author Posts
September 26, 2019 at 5:59 pm

timoB-2

I am trying to:Display new posts in posts page and online

Link to a page where the issue can be seen:hidden link

I expected to see:post with content and in preview page with content

Instead, I got:The page you are looking for no longer exists. Perhaps you can return back to the homepage and see if you can find what you are looking for. Or, you can try finding it by using the search form below.

and if i disable the WPML then things are working fine.

September 26, 2019 at 6:35 pm
September 26, 2019 at 6:37 pm #4649721

timoB-2

hey bobby.. i do not have the email access.. this email belongs to my boss.. so please update the things on the tickets also.. so i will check it.

September 26, 2019 at 8:31 pm #4650175

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

I was able to find the cause of this issue.

This is happening because the wp_icl tables are missing the Auto Increment key from the database.

The following tables are missing their Auto Increment key:

wp_icl_core_status
wp_icl_flags
wp_icl_languages
wp_icl_languages_translations
 wp_icl_message_status.  
wp_icl_mo_files_domains. 
 wp_icl_strings
wp_icl_string_packages
wp_icl_string_pages
 wp_icl_string_positions
 wp_icl_string_status
wp_icl_string_translations
 wp_icl_string_urls
 wp_icl_translate
 wp_icl_translate_job
 wp_icl_translations
wp_icl_translation_batches
 wp_icl_translation_status 

To resolve you need to edit each table and enable AI (Auto Increment).

Once AI is enabled, go to WPML->Support->Troubleshooting->Synchronize Post Taxonomies for both Posts and Pages.

Please let me know if you run into any issues while doing this.

NOTE: When enabling the AI for your wp_icl_translations(main database table responsible for this) you might get an error that an entry for 1 exists already.

In this case, you can view the entries, filter for element_id that is set to 1 and you can remove it. Then try to enabled AI again.

Let me know your results, please and do not proceed without having a backup in place already as you will be changing entries in the database.

September 27, 2019 at 7:05 am #4651943

timoB-2

Hey Bobby,

thanks for quick reply. as per your solution i edit each table and enable AI (Auto Increment).
i have 2 issues which are given below.

Issue 1 :
while these 4 table are missing.
wp_icl_mo_files_domains.
wp_icl_string_packages
wp_icl_string_pages
wp_icl_string_urls

AI (Auto Increment) Done :
wp_icl_core_status
wp_icl_flags
wp_icl_languages
wp_icl_languages_translations
wp_icl_message_status.
wp_icl_strings
wp_icl_string_positions
wp_icl_string_status
wp_icl_string_translations
wp_icl_translate
wp_icl_translate_job
wp_icl_translations
wp_icl_translation_batches
wp_icl_translation_status

so tell me what to do now ?

Issue 2 :-

i am not able to perform that action.
go to WPML->Support->Troubleshooting->Synchronize Post Taxonomies for both Posts and Pages.

Reason : due to language issue. my browser unable to translate the given page. (attached the screen shot for same). so can you please do that for me.

September 27, 2019 at 4:36 pm #4655961

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for updating me.

I have included a screenshot with the option to run in the Troubleshooting page highlighted.

See the dropdown with "beitrage".

Regarding the database tables that are not present:
.. that is ok. They are part of Translation Management, which you are not running on your site.

October 2, 2019 at 8:18 am #4677739

timoB-2

Hey Bobby,

As per your suggestion both changes done from our side. but still have the same issue new posts and pages not coming up.

change 1 : edit each table and enable AI (Auto Increment).
change 2 : go to WPML->Support->Troubleshooting->Synchronize Post Taxonomies for both Posts and Pages.

could you please check and tell us why new posts and pages are not coming up ?

test post which is not coming up : hidden link testgrn /
test page which is not coming up : Permalink: hidden link pagegrn /

October 3, 2019 at 2:36 am #4684003

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Within the database, there are 2 different sets of database tables.

The following are their prefixes:

1. wpstg0_
2. wp_

The wpstg0_ prefix tables are related to the hidden link site, and the wp_ prefix tables are related to the hidden link site.

The database tables that were repaired are from the wpstg0 database
for example wpstg0_icl_translations table when instead it should be wp_icl_translations and all the tables with the wp_ prefix instead of the wpstg0_ prefix.

Please access your database tables and go over the wp_ tables that are still missing the Auto Increment.

Along with the WPML database tables, the standard WordPress tables are missing the Auto Increment as well; for example wp_options.

I have now repaired the tables and the posts and pages are showing as they should.

Please let me know your results.

October 3, 2019 at 8:31 am #4685785

timoB-2

Hey Bobby,

Thanks for the solution. now things are working fine.

I just have a query.

say i create a post in the german language. so is that possible that the automatically a post created with same content in the other language like in English and Suomi ?

or

i have to publish the 3 post in different languages ?

October 3, 2019 at 8:49 am #4685943

timoB-2

My issue is resolved now. Thank you!