Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.01 hours from now. Thank you for your understanding.

This topic contains 4 replies, has 2 voices.

Last updated by francescoL-19 8 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
December 3, 2019 at 1:15 am



I have all my WPML plug-in update. Now, in my WP update page I see:

"New translations are available"

I click the "Update translations" button and everything seems ok.
Then, I refresh the page and.. boom, again the message ""New translations are available"

But, if I disable "WPML Translation Management v 2.9.3 " everything is ok and NO ""New translations are available" message.

Can you help me to understand where is the problem?
I have two website, both with the same error.

Thank you

December 3, 2019 at 2:01 am
December 3, 2019 at 7:50 am #5058101

Shekhar Bhandari

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Our 2nd tier has escalated this issue to our developers.

In the meantime, they have suggested the following workaround, so can you please try it and let me know if this helps:
- go to wp-content/plugins/woocommerce-multilingual/inc/class-wcml-languages-upgrader.php line no. 116 and replace the following

if ( isset( $data->translations ) ) {


if ( !empty( $data->translations ) ) {


December 6, 2019 at 1:40 am #5081103


Hello Shekhar,

thank you but I think I will wait for the next WPML upgrade ^_^

December 6, 2019 at 3:34 am #5081173

Shekhar Bhandari

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Sure, will let you know once the fixed version is released.

December 19, 2019 at 2:22 am #5159409


My issue is resolved now. Thank you!