Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 20 replies, has 3 voices.

Last updated by Nikita Nanos 2 years, 2 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 27, 2017 at 1:51 pm #1414138

Nikita Nanos

I am trying to: Translate website to French using Translation Manager

Link to a page where the issue can be seen: nanos.co

I expected to see: Translations on the website

Instead, I got: None of the new translations can be seen and when I go back into the translation task all the text or any new changes are gone.

October 27, 2017 at 6:58 pm #1414484

Nikita Nanos

Could someone help with this issue?

October 30, 2017 at 8:49 am #1415349

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nikita Nanos,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Sorry for the delays. Please let me know the following for tracking the issue.

1) Does it happen after upgrading to the latest version of a plugin or theme?

2) Please share me few screenshots and the steps you are following for a better understanding.

3) To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

4) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

October 30, 2017 at 4:25 pm #1415955

Nikita Nanos

This is the WPML debug information. I don't think I have access to the wp-config.php. I also don't think I can provide an image to explain what is going on as I can't switch between languages on this page or the home page. I tried to open a ticket in regards to this issue but the link is not working. Basically, I enter the translation on the page in the image below, as you can see everything is marked complete, then I press "Save and close". Today it's stuck on saving and it's just cycling there, but on Friday, it would close, but none of the translated content would show up on the site and when I went back to the translation task, the content would be empty.

October 30, 2017 at 5:13 pm #1416013

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nikita Nanos,

Thank you for the details. I have few more questions to track the issue.

1) Which browser are you using? Please check you are getting the same result for *Translation Save action* in other browsers too?

2) Please check you are getting any JavaScript error in Browser Console when *Translation Save action* stuck.

3) Maybe you are facing this issue because of compatibility issues. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate one by one to see with which one there is an interaction issue

Please check with your hosting provider to access *wp-config.php* file. Because you have to increase the WordPress Memory limit also. Please do the following steps after a site backup for the expected performance of your site.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details.

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Please increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

October 31, 2017 at 1:48 pm #1416858

Nikita Nanos

Hi Bigul,

I have tried using both Chrome and Microsoft Edge to save, neither work.
I believe there is no Java error.

The website hosting company can change the values at a cost (the WP Memory Limit and the MaxInputVars). I just wanted to confirm that these are the only 2 values that need changing, as we can change up to 3.

Finally, can you confirm whether we can have more than one ticket open at a time? I have another issue which is related to switching between languages (some pages will not switch) and I tried to ask a question about that, but the "Open a ticket" link seems not to work.

Thank you.

November 1, 2017 at 12:16 pm #1417762

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nikita Nanos,

Thank you for the updates. We don't need to change other configuration values for the time being.

I would like to access admin area of your site for further checking. Please fill the private details fields after a full site backup. Check the following links for more details about our private information sharing.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

You can open a new ticket for the language switcher issue. Becuase as per our support policies, we can only handle one issue per ticket. Please try to open a new ticket once again and let me know your feedback.

--
Thanks!

Bigul

November 10, 2017 at 8:13 am #1426718

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Bigul is on Vacations so I am taking care of this ticket, hope that is Ok. 🙂

It seems you are using an old version of WPML plugins, so could you please update it the latest version and let me know if that helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Further, Could you please perform the below steps and share me the results?

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Also could you please share the results of the following?
a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate one by one to see with which one there is an interaction issue

Look forward to your reply.

Thanks

November 13, 2017 at 8:42 pm #1429479

Nikita Nanos

Hi,

Yes, we have done this before and the issue isn't fixed.

No plugins seem to be in conflict with WPML, it seems to have just stopped working one day. The theme is also not an issue, as it is compatible and again was working until it just stopped saving.

Is there a way you can access the back end and see what the issue is? I have provided all of this info in previous response.

Thank you.

November 14, 2017 at 5:37 am #1429641

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I just checked this page "Home — Front Page" and I can see that it's working properly, so I am currently unable to replicate the issue. Would you mind providing steps to replicate the issue so I can help you further?

Look forward to your reply.

Thanks

November 14, 2017 at 2:38 pm #1430255

Nikita Nanos

Sorry, maybe there is some confusion about what our issue is.

Our translation is not done for the website, we have been trying to continue translating using your plugin for the last two weeks and nothing is saving. This issue occurred one day all of a sudden after having worked fine all morning.

We have already translated about 3/4 of it but have been unable to finish. All of the FR we added before this issue shows up on the site, but anything we tried to add after did not save or show up on the site (see previous messages above this). We have not been able to add any new FR in about 2 weeks and are getting behind on our launch.

We have already checked by deactivating other plugins and we increased our memory, so I'm not sure what the issue is that keeps anything from saving.

Thank you.

November 15, 2017 at 7:10 am #1430894

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I recently created a page and created a translation too and I can save that translation without any issues. so could you please check the below links? hidden link

Also, I tested this with the manual editor and translation editor so could you please try again to save the translations. and if you are still unable to save the translation please let me know so I can check that page and help you further.

Look forward to your reply.

Thanks

November 15, 2017 at 2:45 pm #1431518

Nikita Nanos

Hi,

We just tried to do this and had the same issue.

We translated an element, saved and closed. The item's status changed to complete but when we clicked it, its empty and no translation has been saved.

I have attached screenshots that demonstrate the issue.

As for your example, I do not see a FR translation when I change the language to FR - or did you only add FR to the end?

Thanks.

November 16, 2017 at 2:42 am #1432096

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

 I do not see an FR translation when I change the language to FR - or did you only add FR to the end?

Yes, I only add FR to the end to test the issue and it's working perfectly. I am little confused about the issue now as it's not happening for me but happens to you.

Are you using local translators to translate this contents? (I mean are you sending this jobs using translations->Translations Jobs).

Look forward to your reply.

Thanks

November 16, 2017 at 1:49 pm #1432734

Nikita Nanos

Hi,

That is odd, I'm not sure why it isn't working for us.

No, we are not using local translators. We are translating this in-house.

Are you able to access our SFTP to see if there is an issue there?

Thank you.