This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This topic contains 48 replies, has 19 voices.

Last updated by danielD-8 1 year, 8 months ago.

Assigned support staff: Amit.

Author Posts
July 10, 2018 at 3:40 pm #2482660

Milosz Jaksik

hmmm it seems there is an issue with custom posts. Additionally I can see "copy media to translation" checkbox but no media is copied.

July 10, 2018 at 3:54 pm #2482731

jasonK-11

I still have the image problem, even after updating to 4.0.4. The feature image is random, although I translated the image file name and said it should use the English version for the English website. Any ideas?

July 10, 2018 at 3:56 pm #2482761

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

@andrer-12 when you click that link, it should take you to a page where you can click "Finish" to complete the media installation (see screenshot). Is that what you are seeing? If not, when you click the link in your screenshot, try checking your browser console to see if any errors are showing up. Here is some information about how to view your browser console: hidden link

If no errors are showing, please open a separate support ticket so that we can further troubleshoot this specific issue.

July 10, 2018 at 3:57 pm #2482793

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

@lucat-17 yes I would suggest deactivating/deleting all WPML plugins and then reinstall the core plugin first, then the rest one at a time.

July 10, 2018 at 4:08 pm #2482871

andreR-12

Dear Lauren,
thank you for the prompt reply.
Yes i takes me to that page. (see screnshot attached)
BUt do ihave to go though all 177 pages?
I don´t get why i should do that.
Everything was good before taht serie of updates.

July 10, 2018 at 4:13 pm #2482905

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

@micheleb-16, you can access your database via phpMyAdmin or through a plugin such as Adminer. Then search for the wpml_notices and clear the value for the field. Be sure you have a full backup of your site before making changes in the database.

@henrietteg-2 WPML 4.0.4 is available at http://www.wpml.org/account/downloads. You can also go to Plugins -> Add New and click the Commercial tab and check for updates. Then you can update directly from the site.

@Piet I think your issue is going to need additional troubleshooting. Could you please open a separate support ticket and be sure to include debug information. One of our supporters will follow up there.

@antonio-IA you can email hello@wpml.org and they will be able to assist you.

@columnD there were many issues caused by the removal of duplicating images. For now, you will need to duplicate the image as you did before 4.0.3. If you duplicate the image, does the featured image display for the translation?

@yunyuz it looks like our supporter Carlos is assisting you now on your ticket. WPML customer support service operates Monday to Friday which is why there was a delay on the reply.

@milosz jaksik If you update the original post and then click update on the translated post, does the media copy? If not, please open a separate ticket so that we can further troubleshoot this issue for you.

@jasonk-11 if you duplicate the image from English to your secondary language, does the featured image show up? You may need to save the original post and then update the translation as well.

@andrer-12 I don't think you need to go through each page, it looks like it is just showing that your images are in the library. If you use the language switcher at the top of the admin page, you should be able to view the separate language media libraries.

July 10, 2018 at 4:19 pm #2482931

andreR-12

Well, teh alert doesn´t go away. It´s in german. I translated it with Google:

The establishment of WPML Media Translation is almost complete. Click here to complete the setup.

I click and see 177 pages with 22 images per page.

July 10, 2018 at 4:23 pm #2482973

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

@andrer-12 so it sounds like your media library is showing close to 3900 images. Does that sound like the correct amount? Does it look like the images are in their correct languages? It could be that the message for some reason just didn't go away. If the images are displaying correctly, you can try clearing the wpml_notices manually in the database. Just be sure to make a full backup of your site before making any changes in the database. If the images are not translated correctly, please open a separate ticket so we can further troubleshoot.

July 10, 2018 at 4:38 pm #2483078

andreR-12

to honest, i don´t know what´s going on anymore.
I´ll try to get a grip on it and get back to you.

July 10, 2018 at 4:55 pm #2483206

lucaT-17

You're great! It works!

July 10, 2018 at 6:22 pm #2483551

jasonK-11

Thanks for the quick reply. What do you mean by duplicate from English to the secondary language? I'm using German to English, but I still don't know what you mean by duplicate from "primary" to "secondary" language. I just resaved the German product, then went into the English translation and resaved. Also went to media translation and uploaded a new file (also tried using the German image). Not working. 🙁

July 10, 2018 at 9:48 pm #2484509

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

@jasonk-11 please go to WPML -> Settings and check your media translation settings (towards the bottom of the page). Do you have the checkboxes ticked to duplicate or translate media? If you have it set to Duplicate from default language to secondary (so from German to English in your case), when you save the product in default and translated version the image should then appear. One more thing to try - you can go to WooCommerce -> WooCommerce Multilingual and on the settings tab, change to use the Native WordPress editor instead of the Translation Editor. With that editor, try uploading a separate image there and let me know if that works.

July 11, 2018 at 12:29 pm #2486610

jasonK-11

"One more thing to try - you can go to WooCommerce -> WooCommerce Multilingual and on the settings tab, change to use the Native WordPress editor instead of the Translation Editor. With that editor, try uploading a separate image there and let me know if that works."

This fixed it, thank you.

July 11, 2018 at 3:06 pm #2487373

columD

@lauren I didn't want to duplicate the image, I simply want the translated page to use the same image as the Main page (English)

So in version 4.0.3 - Use featured image from the original post (English)
^ this works for me

In 4.0.4 - Duplicate featured image from original/to translations
^ this does not work, it doesn't show the image when I've checked this. When you phrase it as "duplicate" does it really duplicate another copy of the image or does it simply using the same image? Please clarify.

July 11, 2018 at 3:50 pm #2487502

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

@columnD using the same image from the original post as you did in 4.0.3 will no longer work. You should be able to duplicate the image, and in the translated page, there is a check box to duplicate the image from the original page. This does not make another copy of the image, just another entry in the database for the translated version. That entry will hold the translated meta info. If it is not working, please try the workaround mentioned here: https://wpml.org/forums/topic/new-wpml-4-0-4-beta-solves-media-issues/page/3/#post-2486610