This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by Rainer 4 years ago.

Assigned support staff: Bruno.

Author Posts
October 8, 2015 at 11:07 am #720429

Rainer

I am trying to: see the single news

URL of (my) website where problem appears: hidden link

I expected to see: news are not shown

Instead, I got: php56_error
Fatal error: Class 'WPML_Root_Page' not found in /srv/www/dictatorint/htdocs/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 3066

October 8, 2015 at 11:15 am #720446

Rainer

Information: I had also the problem 6 weeks before -> WPML support find a solution.
- Yesterday (7.10.2015), I updated to Avada 3.8.7, now the same problem.
- The Avada support didn´t find a solution->recommend ask WPML and deactive and reinstall the plugin..
- I deactivated the WPML plugins with no solution.
- I deleted the Multilingual CMS and reinstall, no solution.
Please help. Thank you.
Rainer

October 9, 2015 at 12:13 pm #721510

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Sorry to hear about the trouble!

As immediate counter action, could you please check file "functions.php" in your Avada theme - is this code block still there?

if ( defined( 'ICL_SITEPRESS_VERSION' ) ){
add_action( 'after_setup_theme', 'inc_root_page_file', 5 );
function inc_root_page_file(){
    require_once ICL_PLUGIN_PATH . '/inc/url-handling/wpml-root-page.class.php';
}
}

In case it isn't please add it back and let me know if this makes a difference?

October 10, 2015 at 10:34 am #722020

Rainer

see the screenshot. I think it`s not only my problem. I have the same problem, no single blog / News on a other project -> hidden link
Please find a solution for WPML witch change it on my page
Thank you for your help

October 12, 2015 at 8:13 am #722485

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Thanks for feedback!

Actually you don't have

if ( defined( 'ICL_SITEPRESS_VERSION' ) ){
add_action( 'after_setup_theme', 'inc_root_page_file', 5 );
function inc_root_page_file(){
    require_once ICL_PLUGIN_PATH . '/inc/url-handling/wpml-root-page.class.php';
}
}

in your functions.php as far I can see. Only the if ( defined( 'ICL_SITEPRESS_VERSION' ) ){} part.

Could you add my snippet to the very end of your file "functions.php" (in the theme) and see if it makes a difference?

--
Btw I was checking in our ticket system. There is a ticket about your this issue here.
Our developers want to solve the problem by implementing a modern "auto_loader" class. But because this auto_loader needs a lot of careful testing it wasn't implemented yet. And the Avada team in turn could not yet adjust there code.
So we need this PHP code addition a bit longer until the auto_loader is implemented.

October 13, 2015 at 6:54 am #723372

Rainer

I switched a second time all plugins on/off. Now I can see the single posts. I´m surprised but lucky 😉
Regards Rainer
*I didn`t do more. ok?

October 14, 2015 at 8:24 am #724448

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Well, strange but good that it works 🙂

Would you mind sending me the "functions.php" of your theme directly via email?
Its andreas.n@onthegosystems.com - thanks!

October 14, 2015 at 9:46 am #724551

Rainer

Done

October 14, 2015 at 5:00 pm #725041

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'm Bruno and I'm handling this issue now.

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Please let me know exactly what steps should I follow to see the problem.

Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

October 15, 2015 at 6:10 pm #726126

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

It looks like it was a problem that is not allowing the "WPML_Root_Page" class be loaded. It seems, however, that the problem was solved when you have disabled the plugins and activated them again.

Please could you check if the problem persists in some other page?

Thank you.

October 15, 2015 at 6:32 pm #726138

Rainer

I found no problem on other pages, thank you !!!