Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 3 replies, has 2 voices.

Last updated by Bernat Torras 3 years, 1 month ago.

Assigned support staff: Bernat Torras.

Author Posts
January 16, 2017 at 12:06 am #1182506


I am trying to: Put my website in spanish, english and french

URL of (my) website where problem appears: hidden link

I expected to see: Another languages, but only appears Spanish

Instead, I got: Only the menu with the English language

Steps to duplicate the issue: i dont know

January 16, 2017 at 8:37 am #1182642

Bernat Torras

Hi @oscarl-11,

Thanks for contacting support, I'll do my best to help you with this! 🙂

I see that your site is all built in one page. I guess this is the reason why the language switcher is not appearing. Could you tell me how is this page built? Is it a regular WordPress page and you've selected it as your homepage in Settings>Reading? Or you haven't created any 'home page' and your theme is generating it dynamically?


January 16, 2017 at 12:20 pm #1182917


I think I have already solved it. Indeed, my website is in One Page and it is configured in "Settings-Reading". Now my problem is this. In the menu of my page (, having added the language drop-down, is too close or overlaps with the logo of the web. How could I put the languages ​​under/over the menu? As a second menu over or under the one I already have.

January 16, 2017 at 1:46 pm #1183009

Bernat Torras


Glad to see that you've already managed to get it working! 🙂

Related to your new question, I think that the best way to achieve this would be by removing the language switcher from your menu and do one of these options:

1- Find the theme file that is calling the menu and rendering all the header section and call a custom language switcher from there (after your main menu).

You can run this function to get a custom language switcher:

<?php do_action('icl_language_selector'); ?>

Or create a new function to create your custom language switcher. You can find more information about this here:

2- Do the same, but create and call a new menu there instead of the language switcher and then add the language selector to it in WPML>Languages

Hope it helps!