This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by Radu 4 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
May 11, 2019 at 9:22 pm

alexanderK-81

I am trying to:

Link to a page where the issue can be seen: hidden link

I expected to see: content and media in other languages
Instead, I got: but all pages in other languages stay empty. The pages are created and the menu is synchronized.

May 13, 2019 at 3:04 am #3794491

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Alexander,

Thank you for reaching out the WPML support!

I just checked the homepage translation in French, for example, and I could see that just a few fields are translated (see the screenshot). Can you try to set the Use WPML's Translation Editor to No (from the right side of the page) just for this page and create the translation once again, as a separate page (not through ATE), please? You can start with the French version first and tell me how it goes.

Thanks,
Radu

May 13, 2019 at 5:57 pm #3801083

alexanderK-81

I added the answer from the theme developer. Could you please have a look and tell me what you think.

Thanks,

Alexander

------ Please reply above this line ------

Hello Alexander,

Thank you for your patience.

We could see the issue on your WordPress install.

We could do the debug and ir could be a bug from WPML with the Advanced Translation Editor. What happens is that not all custom fields are retrieved. I explain in details so you can contact WPML support on your side:
- You have correctly set which custom fields should be translated: hidden link
- But the field "hotelwp_meta_sections" do not appear in the list of field to be translated: hidden link
- However, when clicking on "Finish", it shows the field we would wish to be able to translate: hidden link

We had come across a similar issue with a previous version of WPML where custom fields were not updated but this now seems to be a different issue. I invite you to contact WPML support team to report this problem and see if they can advice you. I checked your WPML settings but to me it seems all correct. Would you please keep me posted?

We will be checking on our side to reproduce the issue on our test install and we will contact as well WPML.

Best regards

Celine
HotelWP Team

HotelWP - Themes and Plugins for WordPress
Available payment gateways add-ons: hidden link
Adomus theme + HBook included: hidden link

May 14, 2019 at 7:25 pm #3810321

alexanderK-81

Hi again,

Could you please help me. I tried wat you told me wit the translation editor set on No and no ATE. Some foto's and text is copied from the site in Dutch to the french and English pages. If that is all what wpml can do than I am not very satisfied with the plugin. In fact there is no translation at all it is just a copy from the dutch site. Can you have a look again and tell me what is wrong with the theme and the translation. At first I was very satisfied with how easy the ATE works and the machine translation was not to bad as well. Thanks, Alexander

May 15, 2019 at 8:33 am #3813637

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Alexander,

I responded a bit late because I was trying to understand what's the structure of the custom fields of the theme. I found that the three custom fields are set to be translatable (hotelwp_meta, hotelwp_meta_sections, and hotelwp_organizer) but, as the screenshots from Celine shows, the field that needs to be translated is called text_img__1_desc. This is why I was looking for the custom fields structure. Can you ask the theme support for creating a wpml-config.xml file for all the custom fields, please? This should do the trick for all the content. Here's an article that you can share with them (that helps building this file) https://wpml.org/documentation/support/language-configuration-files/

As I can see, you no longer use the ATE system. Can you tell me if the pages work as you want now, please? This doesn't mean that going back to ATE is out of the table, I just want to see how things work without it.

Thanks,
Radu

May 20, 2019 at 8:26 pm #3850077

alexanderK-81

Hi Radu,

Below you will find the answer of the HBOOK theme creator. Can you give them your email address or tell them how they can solve the problem with you or somebody else from wpml.

Hello Alexander,

Thank you for the update.

The support team of WPML probably did not realize that the "hotel_meta_section" custom field is a JSON. So "text_img__1_desc" is not a custom field but the name of a name-value pair... So I am afraid the reply is off-topic. 😉

Please do not hesitate to give our email address to Radu from WPML if he wish to contact us directly.

Best regards,

Celine
HotelWP Team

HotelWP - Themes and Plugins for WordPress
Available payment gateways add-ons: hidden link
Adomus theme + HBook included: hidden link

May 21, 2019 at 8:35 am #3853245

aurelien duguerre

Hello Radu,

I am the developer of Adomus theme (with Aurelien, whose WPML account I am logged in to) and I jump in this ticket raised by Alexander, so we can solve this issue together. 😉

As commented, there are 3 custom fields and "hotelwp_meta_sections" is a JSON. I wonder why the content of the hotelwp_meta_sections field is not shown for translation even if it is set to be translated and appear afterwards, as per screenshots provided before.

Best regards,

Celine, HotelWP

May 22, 2019 at 6:33 am #3861351

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Celine,

Nice to meet you!

I downloaded the theme to check it on my local environment for a little. The two fields that contain the JSON are working fine when trying to translate the page (see the attached screenshot).

As I can see, this page hidden link is already set to have the translated pages be as simple pages, created from scratch. I would've like to have another look at the page structure and try to translate the two custom fields but everything should be started over.

Celine, since you are here, can you give a try to our Go-Global program? You can find some more details about it right here https://wpml.org/documentation/theme-compatibility/go-global-program/. Basically, you'll work with our compatibility team to make sure that everything works very well between your theme and our plugins. Also, the theme will be listed here https://wpml.org/documentation/theme-compatibility/ so the customers can see that your product is fully compatible with our plugins.

Thanks,
Radu

May 23, 2019 at 5:37 am #3871247

alexanderK-81

Hi Radu,

Please login my wp site and copy all the content off my dutch version to all the other languages. If I do it, if I ask wpml for it the text and the pictures are not copied at all. In my opinion this has nothing to do with the theme, is it?

I need to go on and attract foreign customers to my website.

Alexander

May 23, 2019 at 12:38 pm #3875059

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Alexander,

I downloaded the Adomus theme from your website to test it on my side. It seems that the two custom fields are not added to ATE even if I'm using a clean website. The content of these two custom fields can be translated using the classic editor or by creating separate pages for each language. I will escalate this to my colleagues and keep you posted about the progress we're making on it.

Thanks,
Radu

May 23, 2019 at 4:49 pm #3878091

aurelien duguerre

Hello Radu,

I ran some tests as well on my side and reach the same conclusion. The custom fields that has a JSON structure is not added correctly for translation when using the ATE. I wait for your colleague reply. 😉 Thanks.

May 24, 2019 at 5:56 am #3881303

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Celine,

Thank you for pointing this out. I added this detail to my colleague, maybe this will speed up the process of identifying the source of the issue. I'll keep you posted about the progress we're making on this.

Thanks,
Radu

May 29, 2019 at 6:31 am #3912089

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Celine,

My colleagues checked this out a bit closer and it seems that the Advanced Translation Editor is made not to send the JSON to translation. This would make the whole system display some other fields too (and everything would get way bigger). We are planning on adding a new extension to ATE to manually see filtered content (like this JSON, for example) but there's no ETA for this new option (at least for now). So, right now, the only option is to keep using the Classic Editor when translating pages that contain custom fields with JSON content.

Regards,
Radu

May 29, 2019 at 7:14 am #3912303

alexanderK-81

Hi Radu,

I understand. For me it's allright to just make a copy of the pages and translate it manually. That works fine. The only problem I have is that I can't translate the strings. If I open a string for translation it shows me the different languages but I can't change anything. It is also the case that all strings appear in English although the sites default language is Dutch. Can you please have a look at that.

Thanks

May 30, 2019 at 10:27 am #3922135

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Alexander,

As I can see, this text is from a widget, am I right? In this case, can you open a separate ticket for it, please? We are trying to keep each ticket with one subject so other users that might have the same question can easily find the solution. Once you'll open the new ticket, we'll have a look at it in no time.

Regards,
Radu