Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 3 voices.

Last updated by Diego Pereira 4 months, 3 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
November 17, 2020 at 12:47 pm #7466383

tobiasL-11

Hello,

I changed the standard language from German to English in the settings of WPML. It happens that there is no content shown for any product.
I noticed different URLs:
hidden link
--> Standard language German, English version of the website
hidden link
--> --> Standard language English, English version of the website

To reproduce the problem, feel free to change anything on this website. It's a test environment.

Hope you can help
Thanks
Franzisak

November 18, 2020 at 4:51 pm #7476745

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

I visited the link you provided, but I can see content in both languages.
Is the issue solved?

November 19, 2020 at 8:48 am #7481079

tobiasL-11

Hello Laura,

there is content in the second link, yes, but the URL is wrong and that's why there is a 402 error. The URL should be like in the first one.

Best
Franziska

November 19, 2020 at 1:24 pm #7484161

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I checked both versions and got the following URL's:
- English: hidden link
- German: hidden link

The content was displayed correctly on both languages. The only difference I noticed is that the english URL have the "?lang=en" parameter, while the German version don't. This is expected because the default language of the website is German.

The only error I got is one related with the SSL certificate (not related with WPML).

Is this correct? If not, could you please send us more details? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

November 19, 2020 at 8:38 pm #7487989

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Updating ticket status.

November 20, 2020 at 10:52 am #7492257

tobiasL-11

Hello Diego,
somehow my answer from yesterday is not showing here anymore -.-
I think there was a missunderstandig....
The two links you checked are total fine, yes. There are the links for the two versions of the product if German is set as standard language.
BUT
If I change this and set the standard language to english, then the URL for the english version of the product is not
hidden link
but
hidden link
This link doesn't exists and therefore a 402 is shown.

So somehow the URLs are not set correctly when changing the standard language

Best
Franziska

November 20, 2020 at 5:56 pm #7494801

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I think this is expected, but I'm not sure if I understood the issue correctly. If you set english as the default language (on WPML > languages > Default Language), the correct URL would be hidden link - it will not have the language parameter, because it's already the default language.

If that's not the issue, could you send us access to your website and the steps to reproduce it? This way it will be easier to understand (and perhaps fix) the problem.

Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT: Please backup a working copy of site files and database before.

November 23, 2020 at 10:20 am #7507657

tobiasL-11

Hello Diego,
yes, this is the issue. I understand why there is no language parameter. But shouldn't this still be a valid URL with tcontent? Otherwise this function of changing the standard language doesn't make sense to me.

Best
Franziska

November 23, 2020 at 3:35 pm #7510795

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I checked the "hidden link" URL and noticed that we have a 404 error. THis happens because the product was created on english language, and it's not translated yet to German (which is the default language).

Could you please translate the english product to German and check if it fixes the issue? Please check this link for more details: https://wpml.org/documentation/related-projects/woocommerce-multilingual/#products

Please let me know if it worked for you.

November 23, 2020 at 3:50 pm #7510891

tobiasL-11

Hello Diego,
the product was created in German and then translated into English with WPML.
So usually German is the standard language.

Now I have the problem, that I want to hide the German version of the website and only show the English (translated) Version of the website. I have to do this because the WPML update which was announced for the beginning of November is still not available and there is an error in the current version.

That's why I changed the standard language to English and disabled the language switcher. Not the best solution, but it would work for now. But when I do this, the problem appears like I described it.
If you tell me, I would have to translte the whole website now again from English into German this is not usefull for me.

If you can tell me if there is another solution, let me know.

Best
Franziska

November 23, 2020 at 7:36 pm #7512041

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

If you want to hide the German language, you can go to WPML > Languages > Hidden Languages, select the German language and save. This way, only the Default language (english) will be available, so no need to hide the language switcher, and it's easy to enable the language again later.

What error and version of WPML are you talking about? If you want, I can also investigate this error to help you. You can download the lastest WPML version here: https://wpml.org/account/downloads/

November 24, 2020 at 10:53 am #7515911

tobiasL-11

Hello Deigo,
thanks for the hint for hiding one language. This is the better version of disableing the second language.

But this doesn't solve the initital problem that I have when I change the standard language to English that the URLs are showing no content.
Do I have to change something in the section "Language URL format"?
At the moment it's set to "Language name added as a parameter" and I read the message "It looks like languages per directories will not function"

The axisting ticket about the WPML problem I have why I have to do all this you can see here: https://wpml.org/de/forums/topic/keine-uebersetzung-mit-woocommerce-dynamic-pricing/

best
Franziska

November 24, 2020 at 2:34 pm #7517909

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks, I checked the other ticket and it seems that the fix will be included on WooCommerce Multilingual 4.11.0.

Please check if the issue with permalinks still happens after these steps:
- Go to Settings > Permalinks
- Re-save your permalink structure

If the issue persist after that, please send us access to your WordPress dashboard (website URL, login and password) I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT: Please backup a working copy of site files and database before.

Kind regards,
Diego

November 25, 2020 at 1:35 pm #7525941

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

The version 4.11.0 is related with Woocommerce Multilingual (WCML), which the current version is 4.10.3. Not WPML.

Thanks for the credentials, I checked the website and found the following configs:
- German is currently select as the default language
- The "boxes" category is translated to "boxen" in german
- Because of that, the correct URL would be hidden link (instead of hidden link)

If you want the same URL on both languages, you need to change the German slug of the category to "boxes" instead of "boxen".

Makes sense? Please let me know if it works for you.

Kind regards,
Diego

November 26, 2020 at 11:19 am #7533913

tobiasL-11

Hello Diego,

sorry I was confused with the realse numbers. Do you have any information on when the next release will be available?

Your explanation wit the URLs makes sense, yes. But it's not practical to manually change all URLs. In the end it doesn't matter to me how the URLs look like.
I need the English version of the website to be visible and the German version to be hidden. Can you tell me how to acheave this the best way?

Thank you very much
Franziska