Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 3 voices.

Last updated by Diego Pereira 4 months, 3 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
November 26, 2020 at 12:38 pm #7534529

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Unfortunately we cannot provide an exact date, but it will be in the next update.

Please try the steps below:
- Backup the website (important, so you can revert if needed)
- Go to WPML > languages
- Click on "Change Default Language", select english and save
- Scroll down to "Hidden languages" and hide the German Language
- Go to Settings > Permalinks and re-save your permalink structure

Please let us now if it worked for you.

Kind regards,
Diego

November 26, 2020 at 12:57 pm #7534801

tobiasL-11

Hello Diego,
where can I find the re-saving of the permalink structure? In the settings I can't see it.

Best
Franziska

November 26, 2020 at 1:02 pm #7534841

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

You need to go to Settings > Permalinks, then just click on "Save". It should regenerate your permalink structure.

Please let me know if it worked for you.

November 26, 2020 at 1:10 pm #7534899

tobiasL-11

hmm ca'nt find it. Im looking here: hidden link

Best
Franziska

November 26, 2020 at 1:45 pm #7535255

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

This is the correct URL: hidden link

It's in the general WordPress settings (not WPML settings).

November 26, 2020 at 2:15 pm #7535461

tobiasL-11

this seemed to work.
But now there is the problem that some content is English and some is German:
e.g. here: hidden link

November 27, 2020 at 1:14 pm #7543477

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I checked the link but it's from the live website, which I don't have access. It seems that the settings are incorrect therem but I'm unable to check (if you want to send the credentials, please let me know so I can enable the private field).

On the test site, the settings seems to be ok, english is the default language and the strings are correctly displayed in english (see hidden link). However I found a different issue, the product page is empty: hidden link - Is this intentional? If you want, I can investigate this.

Kind regards,
Diego

November 27, 2020 at 1:31 pm #7543577
tobiasL-11

Hello Diego,

this happened because some links on the home page on the test site still link to the live site and I din't notice.
So unfortunately the problem still presists.
E.g. you can see all snapboxes we offer here: hidden link
If you open one product, there is no content shown.

Best
Franziska

New threads created by Diego Pereira and linked to this one are listed below:

https://wpml.org/forums/topic/split-no-content-when-changing-standard-language/

November 27, 2020 at 4:50 pm #7545745

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

As the previous issue has already been resolved, I created a new ticket for this new one: https://wpml.org/forums/topic/split-no-content-when-changing-standard-language/

I will reply in the new ticket.

Kind regards,
Diego