This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Carlos Rojas 3 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 16, 2019 at 11:11 am

michaelB-157

I am trying to: Translate

Link to a page where the issue can be seen:

I expected to see: The Editor

Instead, I got: blanc site

July 16, 2019 at 12:32 pm #4220157

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I visited the site and I can see this error message:
Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/.sites/544/site1585579/web/website/wp-content/themes/jupiter/framework/includes/minify/src/Minifier.php on line 227

Please solve this error and let me know if the issue persists?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

July 16, 2019 at 2:28 pm #4221033

michaelB-157

Hey carlos, thanks for this fast feedback

As i know my wp memory limit is at 256 mb.

The „continue“ and „breake“ msg is just a warning (debug mode on) and is cause the new php version

The issue with the editor was before the new php version.

Need further assistance

Thanks and greets
Mike

July 16, 2019 at 2:44 pm #4221279

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,
Thank you very much for your feedback.

Could you tell me if the issue persists with new pages/posts?

If the issue persists with new pages/posts then I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

July 16, 2019 at 3:01 pm #4221465

michaelB-157

- flushed cache
- deactivate all plugins
- activate twenty seventeen
- generate and saved a new blog (carlos test)

the translation editor still not open....

July 16, 2019 at 3:16 pm #4221649

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I just activated the ATE in the languages block that appears in the right column of the edit screen of the post. Could you confirm that the issue is solved?

Regards,
Carlos

July 16, 2019 at 3:29 pm #4221819

michaelB-157

hello carlos, looks good - the editor open

i test one blog with automated translation here:
hidden link

if you switch to english you will see that the blog picture disapear and some page seetings change

AND my main menue change drasticly on translated pages
hidden link

i dont know whats going on to be honest

greets mike

July 16, 2019 at 3:50 pm #4222017

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,
I'm glad to hear that the issue is solved 🙂

As this new issue is slightly different than the original one, I kindly ask you to open a new ticket describing this new issue and assign it directly to me. This way we will be following the forum's rule of having one ticket per issue. This will also help future clients to find answers to similar issues in the forum.

Thank you very much for your understanding!
Best regards,
Carlos

July 19, 2019 at 7:16 am #4244451

michaelB-157

My issue is resolved now. Thank you!

July 19, 2019 at 11:00 am #4245909

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos