This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by agnieszkaK-2 1 month, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
September 3, 2019 at 4:44 pm #4506397

agnieszkaK-2

Dzień dobry.
W ostatnim czasie na mojej stronie dwujęzycznej pojawiają się dwa problemy:
1. Przy aktualizacji wpisu w języku polskim zmienia się na wersję polską cały wpis hiszpański (mimo zaznaczenia opcji nie aktualizuj tłumaczenia).
2. Przy zakupach w sklepie (woocommerce) ze strony hiszpańskiej i płatności przez Paypal, klient nie otrzymuje maila z materiałem do pobrania (produkt wirtualny do pobrania). Każde potwierdzenie trzeba wysyłać ręcznie, również nie otrzymuję informacji o nowym zamówieniu. W wersji polskiej to się nie zdarza.
Jaka może być tego przyczyna?

September 3, 2019 at 8:39 pm #4507239

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Would it be alright with you, if I answer in English?

As far I understood from your message there is a problem with pages that get overwritten with orginal content and that there is not an email be send out on WooCommerce purchases.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin but WooCommerce and WPML and its add-ons.

Do the issues this exist?

If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Let me know about the outcome in order to be able to further assist you.

Kind regards
Andreas

September 4, 2019 at 6:05 am #4508431

agnieszkaK-2

Thank you, Andreas. I’m going to check this solution. 😊
Kind regards,
Aga

September 4, 2019 at 4:16 pm #4512789

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

In case you could narrow down the cause of the issue it would be verz helpful. Otherwise, please provide access and I will take a detailed look into the site.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 5, 2019 at 8:53 am #4517295

agnieszkaK-2

Hi, Andreas. I have one question before I will start to check all things again. Do you speak Spanish? It would be easier for me. I could describe my problem with more details, I suppose.
Regards, Aga

September 5, 2019 at 7:54 pm #4521921

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Si, yo hablo español.

Cordialmente,
Andreas

September 5, 2019 at 8:59 pm #4522035

agnieszkaK-2

Hola, Andreas. Parece que los emails de momento funcionan bien, pero sigo con el problema de traducciones y no llego a resolverlos. En resumen, en este momento cuando escribo un post en polaco luego hago su versión española. Cuando quiero volver a la versión polaca para editar, el plugin cambia la versión española y la sustituye con la polaca (a pesar de marcar la casilla “no actualiza la traducción”). Luego cada vez que edito, tengo que restaurar la última versión de la traducción.
Estoy esperando la copia de seguridad de mi hosting y te daré el acceso.
Saludos, Aga

September 6, 2019 at 2:40 am #4522743

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

para poder investigar mejor el problema necesitaría, si fuera posible, que me permitas acceder a tu sitio temporalmente. Mucho mejor si tuvieras un sitio de pruebas en donde esté replicado el problema.

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

IMPORTANTE

Por favor haz un back up completo de tu sitio y base de datos antes de proveer los datos de acceso
Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

En ese caso, pídeme que vuelva a habilitar una respuesta privada.

Muchas gracias.
Un saludo cordial,
Andreas

September 10, 2019 at 3:54 pm #4547061

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

¿Podrías proporcionarme más información sobre las publicaciones afectadas por el problema?

He probado "Opisywanie zdjęć i mówienie o wakacjach na hiszpańskim" haciendo pequeñas ediciones en el título y el contenido. Luego traduje usando el editor de traducción WPML. No ha habido problemas con el contenido sobrescrito.

Además, tenga en cuenta que hay actualizaciones para nuestros complementos disponibles. Asegurará de hacer los actualizarlos antes de realizar más pruebas.

Saludos cordiales
Andreas

September 10, 2019 at 5:06 pm #4547567

agnieszkaK-2

Hola, Andreas:
Pues, intentaré describirte el problema con más detalles porque ahora hasta a mí me parece complicado. 😊
Cuando preparo una entrada, la versión polaca no siempre es igual que la española porque tengo dos audiencias diferentes y tengo que personalizar las versiones.
Ahora tengo dos opciones:
1.) Preparo la entrada en polaco y elijo la opción traduce con wpml. Entonces se me abre el traductor donde puedo traducir solamente el texto. No puedo hacer nada más, cambiar la foto de portada de la entrada, añadir más medios etc. Solamente puedo traducir el texto. Además, cuando traduzco y quiero prever la entrada, no veo la traducción, o sea, el botón de cambiar de idioma en la entrada.
2.) Preparo la entrada en polaco y elijo la opción traduce con el editor wordpress. Ahora puedo personalizar la entrada, cambiar fotos, añadir medios etc. Cuando quiero prever la entrada ya veo el botón de cambiar el idioma. Cuando ya tengo dos versiones preparadas, no puedo modificar la versión original (en polaco), porque wordpress entonces sustituye la versión traducida con la original. En esta situación tengo que ir a la entrada traducida y restaurarla. Creo que al revés funciona igual. Y solamente de esta manera puedo tener dos entradas que quiero.
Otra cosa es que a veces cuando el usuario tiene que hacer clic en la bandera en la entrada 2 veces para que le lleve a la versión que desea ver.

No sé si he explicado bien todo, igual hago algo mal traduciendo...
Saludos, Aga

September 10, 2019 at 6:32 pm #4548167

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hola,

Gracias por la explicación.

Me di cuenta del problema. La publicación "entrada lengua materna3" como ejemplo se traduce como "Duplicar". Es por eso que se sobrescribe una vez que el original recibe una actualización.

Vaya a la publicación en polaco y cambie el idioma en la barra de administración superior (bandera) a español. Ahora anda hasta la parte inferior de la barra lateral derecha y seleccione "traducir independientemente".

Ahora, la conectividad entre el contenido se deshace y la traducción ya no recibirá actualizaciones cuando el contenido original reciba una actualización. (Ver capturas de pantalla)

Mas informacion sobre el tema:

https://wpml.org/es/documentation-2/traducir-los-contenidos/mostrar-contenido-no-traducido-en-paginas-en-idiomas-secundarios/mostrar-contenido-sin-traducir-por-medio- de-la-duplicacion-de-contenido /

Avísame si necesitas más asistencia.

Saludos cordiales
Andreas

September 10, 2019 at 8:27 pm #4548809

agnieszkaK-2

My issue is resolved now. Thank you!