If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by harrieM 1 year, 11 months ago.

Assigned support staff: Vincenzo.

Author Posts
November 7, 2017 at 6:37 pm

harrieM

I am trying to: get hreflangs in google webmastertools

Link to a page where the issue can be seen: hidden link

I expected to see: posibility to ad international targeting in Google webmastertools

Instead, I got: no hreflang

November 9, 2017 at 10:44 am #1425703

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I checked the HTML source of the page and I can see the hreflang tags are not correctly set.

The problem is that the hreflang tags are in this format:

hreflang="en-us"
hreflang="de-de"
hreflang="es-es"

while they should be like this:

hreflang="en"
hreflang="de"
hreflang="es"

To solve this, follow these steps.

- Go to WPML -> Languages
- Press the "Edit languages" link
- Verify that the Languages tags are set with only two letters as shown in the following article:
https://wpml.org/documentation/support/adding-hreflang-wordpress/

If the Language tags are correctly entered with 2 letters (en, de, es) then please try the workaround explained in this article:
https://wpml.org/errata/hreflang-does-not-use-the-language-tag/

You can verify if the fix worked by looking at the HTML source of the homepage or by using an hreflang validator.
- hidden link

Please let me know if this solves the issue or if you need help applying the fix.

Thank you

November 16, 2017 at 9:05 pm #1433251

harrieM

I've made the changes you suggest, but Google does still not 'see' my HREFLANGS!
In the search Console (dutch): Uw site bevat geen hreflang-tags.
When i look into my source there's:
<link rel="alternate" hreflang="nl" href="hidden link" />
<link rel="alternate" hreflang="en" href="hidden link" />
<link rel="alternate" hreflang="de" href="hidden link" />
<link rel="alternate" hreflang="es" href="hidden link" />
Looks good? What went wrong?

November 17, 2017 at 10:23 am #1433644

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I just tested your website with this SEO tool and everything is correctly setup:
hidden link

It failed at my first attempt because I used the HTTP protocol instead of the https in the URL.

Can you please verify if your site is registered to Google with the HTTP URL instead of the https one?

Thank you

November 17, 2017 at 3:42 pm #1434115

harrieM

Hi Vincenzo, yes both versions (www and non www) are registered with httpS..

November 17, 2017 at 4:14 pm #1434152

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

can you please give me more details about the errors in the Google search console (error messages, screenshots)?

Sometimes it requires time before Google crawls again the site.

You can also try changing the "Position of hreflang links" from WPML -> Languages -> SEO Options

Thank you

November 25, 2017 at 9:07 am #1441071

harrieM

Hello, The problem is still not solved! Google does not see my HREFLANG and there are no errors in Google webmastertools vissible. I tried all you suggested (also change position of the HREFLANG in the header) but nothing is working...? I gave you login for this website, but till now you didn't use it. Please give GOOD support and have a look insite... For me WPML is not what i expected now i can't use the International targeting (HREFlang) in Google webmatertools...
Please take my problem serious!

November 25, 2017 at 9:48 am #1441095

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I can understand your frustration about this issue.

I can assure you that I did all the steps available to me to debug this issue from WPML perspective.

From what I can see in the HTML source of your pages, WPML is correctly rendering the hreflang tags.
This is clearly confirmed by these four external testing tools:
- hidden link
- hidden link
- hidden link
- hidden link

Just visit those pages and enter your website's address prefixed by https:// (eg. hidden link )

I advise you to contact Google's support and ask why they are not identifying the hreflang tags on your pages.

Please let me know the results of your tests and any answer from Google's support.

Thank you

November 29, 2017 at 5:26 pm #1445091

harrieM

Hello,

Where can i find 'Google support'?

gr.

November 30, 2017 at 11:30 am #1445717

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

you can use the Webmaster Central Help Forum here:
- hidden link

Thank you

November 30, 2017 at 12:18 pm #1445825

harrieM

I'm wainting for indexing by google. HREFlangs could be oke...