This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Rajeeb Banstola 3 months, 1 week ago.

Assigned support staff: Rajeeb Banstola.

Author Posts
June 5, 2019 at 2:48 pm #3961775

patrickF-31

According to the Search Console, my site does not include any hreflang tag. This is not normal since the site is now fully translated from English to French.
Can you help please?

June 6, 2019 at 2:47 am #3965305

Rajeeb Banstola

Hi,

Thank you for contacting WPML!

Please go to WPML -> Languages -> SEO Options and check the box saying "Display alternative languages in the HEAD section". This will add the required hreflang tag in the head of the document.

You can find more information on the SEO Option here:

https://wpml.org/documentation/support/adding-hreflang-wordpress/

Let me know if this resolves your issue!

June 6, 2019 at 5:21 am #3965913

patrickF-31

It’s already checked, with option “as early as possible”. This is the first thing I verified.

June 6, 2019 at 8:47 pm #3971943

Rajeeb Banstola

Hi,

For being of better help, can you please provide me with WPML Debug information in the debug field below?

http://wpml.org/faq/provide-debug-information-faster-support/

Best,

June 7, 2019 at 5:27 am #3974091

patrickF-31

Debug information provided

June 7, 2019 at 9:35 pm #3979143

Rajeeb Banstola

Hi,

Thank you for providing the debug information.

I see that only your homepage doesn't have the hreflang tag. I checked couple of other pages and all of them have it.

This is WordPress default behavior since the "home" is set to display blog posts and you do not seem to have any blog posts. Please let me know if that's not the case.

As a workaround, create a single post and translate it to both of your languages. You can set this post to no-index and doesn't have to be displayed anywhere.

Once you do this, the hreflang tag will appear for your homepage as well.

Let me know if this helps!

June 8, 2019 at 5:10 am #3980591

patrickF-31

Hi Rajeeb
I have done what you suggested. Could you please check if the tags are now present in the home page? Still no change in Google Search Console but maybe it takes time to refresh?
Thank you

June 11, 2019 at 4:32 am #3991861

Rajeeb Banstola

Hi,

I still can't see the hreflang tag on your homepage. Can you please provide me admin username and password to your site? I'll like to try a few things in order to identify the issue.

June 11, 2019 at 7:05 am #3992301

patrickF-31

What is your e-mail?

June 11, 2019 at 5:37 pm #3997775

Rajeeb Banstola

Hi,

You can use any of your email. I've marked your next reply as private and enabled boxes to add your WordPress login details.

June 11, 2019 at 6:33 pm #3998061

patrickF-31

I prefer to create a new user for you to use. Please send me your e-mail ID.
Thank you.

June 12, 2019 at 6:58 pm #4007223

patrickF-31

OK I will create a new user with one of my e-mail addresses. Please activate secure form.

June 13, 2019 at 2:15 am #4008403

Rajeeb Banstola

Hi,

I've activated the private reply.

June 14, 2019 at 3:43 am #4018205

Rajeeb Banstola

Hi,

I'm very sorry that this is taking a long time.

I was unable to login using the details. Please confirm the details and let me know. I've marked your next reply as private as well.

June 15, 2019 at 7:06 am #4025719

patrickF-31

Hi Rajeeb
I have noticed your connection. Have you identified the issue?
You had inactivated SSL and the site could not work any more. I have reactivated it.
Also noticed Jetpack is broken: impossible to set-up. I am receiving an error message which says that Jetpack cannot connect to my website, it's timing out. I have reinstalled it but no success.
Have you made changes which are causing this issue?

For now I have to proceed with a full restore.
Please inform me when you get online. Thank you.