Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to translate logo in English, but its not working.

Solution: I have translated the logo by performing the below steps:

- Go to String Translation - Click on ‘Translate texts in admin screens’ link - Open ‘astra-settings’ tree view - And checked logo ‘transparent-header-logo’, ‘ast-header-retina-logo’ checkboxes as in attached screenshot - Then add translation of logo as in attached screenshot.

Please clear your browser cache and take a look on it. Screenshots here: 1. https://cdn.wpml.org/wp-content/uploads/2018/05/1936643-logo_enable.png?x30111 2. https://cdn.wpml.org/wp-content/uploads/2018/05/1936643-logo_translation_added.png?x30111 3. https://cdn.wpml.org/wp-content/uploads/2018/05/1936643-logo_frontend.png?x30111

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 5 voices.

Last updated by dorM 3 years, 4 months ago.

Assigned support staff: Noman.

Author Posts
April 28, 2018 at 3:25 pm

Axel Axelsson

I am trying to: use domain for langue

Link to a page where the issue can be seen: zenfors.se/hem / zenfors.com/home

I expected to see: logo

Instead, I got: no logo on english side

April 28, 2018 at 6:35 pm #1877669

Axel Axelsson

I needed to reinstall image

April 28, 2018 at 7:03 pm #1877774

Axel Axelsson

ups . . . now logo is not showing on Swedish side.

April 30, 2018 at 3:27 pm #1900495

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

- Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Go to WPML -> String Translations
- Translate the string for the logo URL, with your translated logo image URL (this will be your translated image for the logo).

If the logo image is set using the theme options. You need to translate Logo option using String Translation:

- Go to WPML >> String Translations >> Translate texts in admin screens »
- Search for the zenfors_settings >> Logo key and expand it with the +
- Select logo URL checkbox option
- Scroll all the way down and press the 'Apply' button
- Go to WPML >> String Translations
- Translate the string for the logo URL, with your translated logo image URL.

Thank you

May 1, 2018 at 11:14 am #1911695

Axel Axelsson

Hello Noman,

Thanks for your replay.

I changed max memory setting.

I can't find the string for logo url.

How to fix ?

May 1, 2018 at 11:31 am #1911876

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I would just like to let you know that Noman is not available today.
Since he has all the information about the issue in your ticket, I think that it will be best if you wait for him to continue investigating this issue tomorrow.

Thank you for your patience,
Itamar - WPML support team.

May 2, 2018 at 8:15 am #1924525

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- Please increase MaxInputVars to 10000 or more. For this, please try to set this variables in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

- Please upgrade your server’s MySQL version to a higher level: https://wpml.org/home/minimum-requirements/
MySQL 5.5.5 version in your site, is lower than the required for WPML.

=== If still issue persists, please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important

Thank you

May 2, 2018 at 8:27 am #1924639

Axel Axelsson

Hello Noman,

Thanks for your replay.

I added the code to php.ini

I'm checking mySQL version.

You can disable plugins and themes as needed.

May 2, 2018 at 2:57 pm #1936643

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have translated the logo by performing the below steps:

- Go to String Translation
- Click on ‘Translate texts in admin screens’ link
- Open ‘astra-settings’ tree view
- And checked logo ‘transparent-header-logo’, ‘ast-header-retina-logo’ checkboxes as in attached screenshot
- Then add translation of logo as in attached screenshot.

Can you please clear your browser cache and take a look on it.

Thank you

logo frontend.png
logo translation added.png
logo enable.png
May 2, 2018 at 6:28 pm #1940848

Axel Axelsson

Thanks.

July 16, 2018 at 12:45 pm #2528093

dorM

Hi,
tried the following also on Astra theme, but after step 4 i cant find the string in Translation Management. what is wrong?

July 19, 2018 at 1:51 pm #2534909

jonathanF-3

Hi, same here using the Astra theme. I've checked the ‘transparent-header-logo’ in "translate text in admin screen" but once I go back to the string translation screen, the field isn't there.

July 23, 2018 at 5:43 pm #2570896

dorM

i guess no help around here? is the solution is to switch to another theme?