This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.50 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by Noman 1 year, 5 months ago.

Assigned support staff: Noman.

Author Posts
May 7, 2018 at 6:29 am #2003126

nicoloM-7

I am trying to: save the translated articles

Link to a page where the issue can be seen: hidden link

I expected to see: the article saved

Instead, I got: the saving icon always loading

I translated all the pages and the first article of the website (hidden link) but I can't get to translate the other articles as the icon saving is always running and the articles didn't save.
I have read on this forum similar issues, I increased the memory of WP and now it's 256MB but still it doesn't work.

May you please help me?

Thanks a lot.

May 7, 2018 at 4:06 pm #2016026

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support.

- Please increase MaxInputVars to 10000 or more. For this, please try to set this variables in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

- Please enable error reporting at you site and let me know if any error found.
To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_DISPLAY', true );

For more details:
https://wpml.org/documentation/support/debugging-wpml/

- Please clear all sort of caches in your site plugin cache ( WP Fastest Cache) / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

Please delete the translated page and again add translation.

- Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

May 7, 2018 at 4:39 pm #2017349

nicoloM-7

Ok thanks. Where can I find the php.ini file? I allowed the visualization of hidden files but I am unable to find it.
I also checked on PhpMyAdmin interface.

Thanks.

May 7, 2018 at 4:42 pm #2017380

nicoloM-7

Is it the same if I add a line on my .htaccess file with the code you provided me?

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

Thanks.

May 8, 2018 at 6:52 am #2024113

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Where can I find the php.ini file?

Please follow the below steps to find the php.ini file:
https://stackoverflow.com/questions/6185319/how-to-locate-the-php-ini-file-xampp#answer-17502290

If you want to update through .htaccess please add following code:

php_value max_input_vars 10000

For more details:
hidden link

Please backup .htaccess file first as .htaccess file some time generate issues when we add above code in it.

You can ask from your hosting provider to update those values.

Thank you

May 8, 2018 at 8:36 am #2025361

nicoloM-7

I have updated the file. I can see the canges within the WPML assistance panel, but I have still the sam problem. The icon is spinning and the English articles are not saved...

May 8, 2018 at 9:28 am #2026420

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- I have noticed that you are using older version (4.2.6) of Enfold theme and latest version of Enfold theme is 4.3.1, please update the theme and let me know if this resolves the issue or not.
hidden link

- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Backup your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.
Could you tell me the result of this steps?

Thank you

The topic ‘[Closed] No more able to save the translation, it was working but now it's just loading’ is closed to new replies.