This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Raja Mohammed 1 month ago.

Assigned support staff: Raja Mohammed.

Author Posts
September 13, 2019 at 4:02 am #4565371

ouD

I am trying to view media by page in order to translate image file name and alt text.

From the tutorial videos, we are told that when selecting pages for translation in Translation Management, we will have the option to send the media for translation as well.

However, no media options show up when selecting the page. This could be because the images are embedded on my pages using custom fields through a page builder (Live Composer).

All I need is a way to view my images per page, then edit the image files and alt texts on that page. What's the best way to do this?

September 13, 2019 at 9:14 am #4566901

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello There,

If custom fields are used to create the content then you should set the custom fields to translatable to make it available for translation.

- Open the page edit screen in the default language,
- Scroll down to Multilingual Content Setup section,
- Search for the custom field related to the images and set the field to "Translate",
- Apply the settings and update the page.
- Try to send the translation from TM Check if that helps.

Kind regards
Raja

September 18, 2019 at 1:15 am #4591429

ouD

Hi Raja,

My custom fields are dlsc type. I've enabled these to be translatable from the WPML settings. Still, when I select the pages in translation management, no media shows up for me to select.

Is there any other way for WPML to access my images for translation? Such as through the media library and viewing media by page?

September 18, 2019 at 11:09 am #4595493

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please provide temporary access to your site. Let me check this in detail. I have enabled private fields for you to securely share the details.

September 19, 2019 at 11:13 am #4604191

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I think i need more information on this case,

- Please let me know the page where I can see the issue

- Live composer is not compatible with WPML and hence images attached to it may not be available in the translation editor

- I am not clear about the custom field is it added by the theme or through live composer editor

Alternatively, you can translate all the media from WPML > Media Translation, The media translation also allows you to change the Media for translation. This is the preferred method if the page builder is not supported by WPML.

September 20, 2019 at 1:09 am #4608547

ouD

Live Composer is active on every page of our website, so the problem occurs on every page. You can look at our Spanish pages > Home page as an example.

I believe the dslc fields are created by live composer, but I'm not 100% certain.

I'd be happy to translate our images through Media Translation, however we can't sift through thousands of images. We need to be able to view media by page. Is there any way to do this? Maybe a plugin for WP Media Library that can arrange images per page, and then Media Translation can view them arranged like this?

September 20, 2019 at 6:48 am #4610021

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I'm afraid I don't see any other solution in this case.

Since Live composer is not compatible with WPML. The only way to translate the media files is to manually do them from the WPML > Media Translation section as mentioned in my previous reply.

I really wish I could help with an alternate solution, Unfortunately I don't have any 🙁

The topic ‘[Closed] No Option to Translate Media’ is closed to new replies.