This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Raja Mohammed 3 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
June 2, 2019 at 6:17 pm #3937925

hlaingM

I am trying to: see the photos when the 2nd language switch is ON.

Link to a page where the issue can be seen:

This is the original ad including the photos posted in English.
hidden link

This is what you see with NO photos when the 2nd language switch is ON.
hidden link

I expected to see: the photos when the 2nd language switch is ON.

Instead, I got: No photos.

June 3, 2019 at 8:34 am #3940131

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome back 🙂

Please clarify does it happen only on that particular ad or its a random issue ?

Please update the original ad and the translation does it help?

If not please follow the below settings.

Please go to WPML > Settings > Media Translation
select the options and click start
[x] Translate existing media in all languages
[x] Duplicate existing media for translated content
[x] Duplicate the featured images for translated content

Wait for the process to complete.

Please let me know the results.

Kind regards
Raja

June 3, 2019 at 10:31 am #3941557

hlaingM

Hi Raja,

I followed your steps and it does not work.

I posted another ad (My pirate (3-colored) female cat missing) in English to check.
hidden link

When the 2nd language switch is ON,
(1) No photo is copied
(2) No ad description is copied. The ad description is simply automatically copied from the texts from the homepage background photo/search area and they are not the original/actual ad description.

I want to ensure that when a user posts an ad, it should be displayed as it is in both languages without having any assistance from the admin or requiring any additional steps from the users.

Thanks.

June 4, 2019 at 5:01 am #3947981

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Please confirm the media settings for new media under WPML > Settings > Media Translation
=> How to handle media for new content:
Check all the settings
[x] When uploading media to the Media library, make it available in all languages
[x] Duplicate media attachments for translations
[x] Duplicate featured images for translations

Click apply, Try posting a new ad and share the results. If it is still an issue. Kindly share temporary access to your site. I will have a closer look at the issue.

Kind regards
Raja

June 4, 2019 at 10:45 am #3950473

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI,

I think I have fixed the issue, The Ad image is handled by a custom field _add_media,
I have set the translation preference of the images to be copied to the translation and updated the original post this help me fix the missing images in the ads and its translation.

Please test with a new Ad let me know if this works perfectly.

Kind regards
Raja

June 4, 2019 at 2:28 pm #3952733

hlaingM

Hi,

Where exactly did you change those settings? Could you please describe the steps.

The action you performed only copies the ad in the latest listings, but NOT in the featured listing.

For instance, I just posted a new ad "1 Year old white Pom missing" with the featured listing option. You don't see the ad copied in the featured listings. Previously, only the photos are not copied as in the ad "My cat missing for 1 week". But, now nothing is copied in the featured listings from English to the 2nd language. You can check it yourself at the links below.

hidden link

hidden link

Thanks.

June 6, 2019 at 3:14 am #3965507

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

To copy the images to the translation, I did the following.

-> Goto WPML > Settings > Custom fields translation
-> Select show hidden fields
-> Search for the field _add_media and marked it as "Copy Once"
Screenshot attached

Regarding your second claim, I can verify from the backend the ad "1 Year old white Pom missing" is not marked as a featured listing, I'm not sure if it can be marked from the frontend. I have marked it as featured now it's displaying in the featured list with the images.
Please verify the same

Kind regards
Raja

June 6, 2019 at 5:15 am #3965859

hlaingM

Hi,

Thank you for your responses.
(1) What is the difference between 'copy once' and 'translate'?

At my site, the admin is NOT supposed to assist from the BACK-END in posting ads posted by the users. So if the users post an ad with the "featured listing option", I want to make sure that everything including photos is copied to the 2nd language in both featured listings and the latest listings. So far this is not happening.

(2) I just submit an ad "zebra cat missing" with photos in English, but the photos are still missing in the latest listings of the 2nd language.

Could you please help to resolve the issue? Thank you.

June 6, 2019 at 11:49 am #3968895

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

1)" Copy once" will copy the content from original (default) language to the translation which can be changed by the user while translating from the backend.

"Translate" Will not copy anything from the original but allows the user to add content in translation.

2) I don't see the translation of the post "zebra cat missing" in Myanmar language, the earlier ads seem to be duplicated to the translation and maybe this is related.

However, I see the there is some other issue related to the images custom field it is having only the system fields and the user-visible fields is missing. Is there a way to customize the Attachment custom field in the theme?

Kind regards
Raja

June 6, 2019 at 1:23 pm #3969467

hlaingM

Hi,
The file attachment is default, fixed and present in every form. It can neither be removed nor added.

If you dont see my ads, you can try to post an ad choosing an featured ads listing option and see for yourself.

Thank you.

June 7, 2019 at 10:57 am #3975593

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I need some information here, If I remember correctly in another ticket with yours the theme had an issue with duplicating the ads created in the frontend, Could you please explain how it is handled now ? have you created any custom coding to add this feature?
Since the backend ad creation seems to work fine this seems more like a front end issue.
Details about it would be of better help in this case.

Kind regards
Raja

June 7, 2019 at 4:43 pm #3977761

hlaingM

Hi,

In the previous ticket, we discussed about the issue concerned with copying the ad posted using the 2nd language to English since WPML ONLY has the capability to copy ads posted in default English to the 2nd language. I hired a developer to work on it and it was finished from what I tested last week.

Current issue is concerned with copying ads from default English to the 2nd language: specifically, (1) copying the photos posted in English to the 2nd language which is the priority (I have not checked if the photos posted in the 2nd language are copied to English)
(2) copying ads posted with featured listing option in English to appear in the featured listing of the 2nd language in addition to their appearance in the latest listing of the 2nd language. Please note that if the ad posters do not use the featured listings option, the ads including the photos are supposed to appear in the latest listing section of both languages.

Thank you.

June 10, 2019 at 11:09 am #3987011

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This is quite strange. I might need to test this in a sandbox installation to reproduce the issue. The sandbox we have created earlier has expired.

One Click Login:hidden link

Please install the theme and create a dummy ad in default language with gallery images WPML is already installed please complete the setup,

I am sorry I had to ask you to perform these steps again since this is the elegant way we can easily identify the issue and resolve it as soon as possible I would kindly request your assistance in this regard

Kind regards
Raja

June 10, 2019 at 8:10 pm #3990145

hlaingM

Hi,

I was not able to set it up at the link you provided. However, I already set it up at the following link. I posted 2 ads using photos, one in English and the other in the 2nd language as the names of the titles suggest. Please choose "VIP" for "featured ad listing".

hidden link

Please let me know if you have any questions. Thank you.

June 11, 2019 at 7:10 am #3992333

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks, it seems like sandbox is having some issues,
I am sorry I don't have the access to the sandbox link which you shared.
Please share the one-click login link for this site hidden link

Kind regards
Raja