This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.55 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Content (pages, posts) are missing on admin dashboard after installing/activating WPML plugin.

Solution:

uninstalling WPML completely and re-installing WPML resolves the issue.

Steps:

-backup your site completely (important!)

-reset WPML by Going to WPML >> Support >> Troubleshooting >> There, click on “Reset and deactivate WPML” - this action will remove WPML tables (tables with the 'icl_' prefix) from the database.

-deactivate/delete all WPML plugin

-deactivate all non-WPML plugins

-download a fresh copy of WPML plugin from your wpml.org account.

-install/activate WPML plugin

This topic contains 8 replies, has 2 voices.

Last updated by zolM 3 months, 2 weeks ago.

Assigned support staff: Dennis.

Author Posts
July 2, 2019 at 8:06 am #4124863

zolM

Hi,

I've purchased and installed WPML, all my posts are now gone. I go to Post section of my wordpress site and it shows "No posts found."

From my browser history I click on a post that was previously working prior to installing WPML and it redirects me to 404 The page you were looking for could not be found.

I can see under Posts

All (150) | Published (141) | Sticky (1) | Drafts (9)
English (0) | French (0) | Spanish (0) | All languages (0)

Only when I deactivate or delete WPML I get my website back to normal. What is causing this problem?

Thanks

July 2, 2019 at 9:17 am #4125291

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please share your Debug information with me? You can read the detailed explanation about it here.

http://wpml.org/faq/provide-debug-information-faster-support

The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Meanwhile, could you please try these steps and see if it resolves the issue?

Note: Please make sure to make a complete backup of your site before proceeding.

-Go to WPML>>Support page
-Click on Troubleshooting link (link in the middle of the page)
-In Troubleshooting page, please click on the following options of 'Clean up' section. Wait for confirmation of processing after each one.
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
-Recreate ST DB cache tables

If the issue still persists, please check if this issue appears when:

- All non WPML Plugins are disabled. It will tell us if there is an interaction issue with other plugin.
- Theme is set to a WordPress default like Twenty Sixteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

Note: Please backup your site completely before doing this test.

Please let me know your results.

Kind regards,
Dennis

July 2, 2019 at 3:44 pm #4128521

zolM

Here is the debug

July 3, 2019 at 2:04 am #4130797

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for providing us with the debug information.

Please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Could you please share your results after doing the suggested troubleshooting steps from my previous message?

Thank you.

Kind regards,
Dennis

July 3, 2019 at 6:08 am #4131941

zolM

Thanks I increased WP memory via wp-config and all non WPML Plugins disabled but the problem still there, all posts gone. Seems like WPML doesn't work for me so I guess is time for a refund.

Honestly I thought this was a simple installation, nobody should have to go through all this steps to waste time and money.

July 3, 2019 at 8:41 am #4133371

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Sorry to hear about the inconveniences. The issue could be due to possible plugin conflict and/or a glitch occurred during the installation.

You can submit a refund request via this form here: https://wpml.org/purchase/refunds-policy/

Kind regards,
Dennis

July 3, 2019 at 7:56 pm #4138759

zolM

But I disabled all plugins and the problem still persists, so it has something to do with WPML. I have deleted WPML from my website and installed it again and the same.

From videos I've seen on Youtube I don't have the same installation steps even from the same version of 2019

July 4, 2019 at 3:41 am #4140155

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Looks like that a glitch occurred during installation, thus need re-installing. However, before re-installing WPML your have to RESET it first. Please try this steps:

-backup your site completely (important!)

-reset WPML by Going to WPML >> Support >> Troubleshooting >> There, click on “Reset and deactivate WPML” - this action will remove WPML tables (tables with the 'icl_' prefix) from the database.

-deactivate/delete all WPML plugin

-deactivate all non-WPML plugins

-download a fresh copy of WPML plugin from your wpml.org account.

-install/activate WPML plugin

Does it help? Please let me know.

Kind regards,
Dennis

July 4, 2019 at 4:54 am #4140343

zolM

My issue is resolved now with your last instructions. Thank you!