This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by dennisV-38 6 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
March 28, 2019 at 5:25 pm

dennisV-38

I am trying to: Translate products

Link to a page where the issue can be seen: hidden link

I expected to see: a list of already entered products through the native product add screen now ready for translation.

Also the already translated Categories and Attributes they where OK but are no longer there, they are there but the system gives a warning.

Instead, I got:

March 28, 2019 at 11:59 pm #3486127

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

I am not able to access your wp-admin. The login leads directly to hidden link

Please enable the wp-debug feature to see if there are any current PHP errors given.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Follow the steps by including the mentioned code lines inside the wp-config.php

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );

Then visit your website on front end or backend.

A debug.log file will be created once WordPress detected an error. The debug.log can be found in the folder wp-content.

Let me know about the error report results in order to assist you.

Apart from this issue could you please increase your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Kind regards
Andreas

March 29, 2019 at 8:28 am #3488949

dennisV-38

Hello The only error Is from a shipping module;
Notice: Undefined index: in /home/dennikc221/domains/phaserrcruisers.com/public_html/wp-content/plugins/woocommerce-myparcel/includes/class-wcmp-frontend-settings.php on line 134

For login you can try hidden link

My problem looks like this ticket: https://wpml.org/forums/topic/products-not-showing-in-woocommerce-multilingual-screen/

March 29, 2019 at 8:30 am #3488991

dennisV-38

This is the log file;

[29-Mar-2019 08:54:54 UTC] PHP Notice: Undefined index: in /home/dennikc221/domains/phaserrcruisers.com/public_html/wp-content/plugins/woocommerce-myparcel/includes/class-wcmp-frontend-settings.php on line 134
[29-Mar-2019 08:54:54 UTC] PHP Notice: Undefined index: in /home/dennikc221/domains/phaserrcruisers.com/public_html/wp-content/plugins/woocommerce-myparcel/includes/class-wcmp-frontend-settings.php on line 134
[29-Mar-2019 08:54:54 UTC] PHP Notice: Undefined index: in /home/dennikc221/domains/phaserrcruisers.com/public_html/wp-content/plugins/woocommerce-myparcel/includes/class-wcmp-frontend-settings.php on line 134
[29-Mar-2019 08:54:54 UTC] PHP Notice: Undefined index: in /home/dennikc221/domains/phaserrcruisers.com/public_html/wp-content/plugins/woocommerce-myparcel/includes/class-wcmp-frontend-settings.php on line 134
[29-Mar-2019 08:54:54 UTC] PHP Notice: Undefined index: in /home/dennikc221/domains/phaserrcruisers.com/public_html/wp-content/plugins/woocommerce-myparcel/includes/class-wcmp-frontend-settings.php on line 134
[29-Mar-2019 08:54:54 UTC] PHP Notice: Undefined index: in /home/dennikc221/domains/phaserrcruisers.com/public_html/wp-content/plugins/woocommerce-myparcel/includes/class-wcmp-frontend-settings.php on line 134
[29-Mar-2019 08:54:55 UTC] PHP Notice: Trying to get property of non-object in /home/dennikc221/domains/phaserrcruisers.com/public_html/wp-content/plugins/Betalen-in-termijnen-plugin-voor-WooCommerce-Basis/woocommerce-gateway-gespreid-betalen.php on line 80
[29-Mar-2019 08:55:09 UTC] WordPress database error Table 'dennikc221_wp508.b2s_user' doesn't exist for query SELECT token FROM `b2s_user` WHERE `blog_user_id` = 1 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, B2S_Loader->load, B2S_Loader->call_admin_hooks, B2S_Loader->getToken
[29-Mar-2019 08:55:09 UTC] WordPress database error Table 'dennikc221_wp508.b2s_user' doesn't exist for query INSERT INTO `b2s_user` (`token`, `blog_user_id`,`register_date`,`state_url`) VALUES ('v3_eRO0iV5BZ4L0PYYM9PJIHM1yL8oLgFh2rR1mmJ2v-ASQvZX2QX2-z2uuDmpBXK95wh3zF8j9JoNrKBftrLg-aABikVEySc2uLqm_FfqQUjeLzMTkxJ28WTglf0Youx9uYghLdn9L7_SUqlfaR7ze8g,,',1,'2019-03-29 08:55:09',1); made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, B2S_Loader->load, B2S_Loader->call_admin_hooks, B2S_Loader->getToken
[29-Mar-2019 08:55:10 UTC] WordPress database error Table 'dennikc221_wp508.b2s_posts' doesn't exist for query SELECT posts.id, posts.v2_id, user.token FROM b2s_posts as posts LEFT JOIN b2s_user AS user on posts.blog_user_id = user.blog_user_id WHERE hook_action = 3 AND post_for_approve = 0 made by do_action('wp_ajax_heartbeat'), WP_Hook->do_action, WP_Hook->apply_filters, wp_ajax_heartbeat, apply_filters('heartbeat_received'), WP_Hook->apply_filters, B2S_Heartbeat->init, B2S_Heartbeat->deleteUserSchedPost

March 29, 2019 at 10:18 am #3490153

dennisV-38

I sloved the issue, I have update all products with Bulk action now they are displaying. I think you have to put this in the manuals if you have existing products you need to Bulk update all products

March 29, 2019 at 6:22 pm #3493867

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your update.

I will create a summary in this ticket that will help other clients to solve similar issues.

Usually the product are importing in the WCML setup. For some reason the setup must have been canceled before completing the task.

Please fell free to contact us again if you need assistance and feel free to mark this ticket as solved.

Kind regards
Andreas

April 4, 2019 at 2:44 pm #3535965

dennisV-38

My issue is resolved now. Thank you!