This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 41 replies, has 3 voices.

Last updated by adriO 1 year, 2 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 2, 2018 at 4:50 pm #1562483

adriO

And again.... I'm not able to post with an image attached....
What is going on?

It says: WooCommerce Multilingual is enabled but not effective. It is not compatible with WPML Media versions prior 2.3

A bit of a messy sequence of posts but it's your system that is messing things up. 🙂

April 2, 2018 at 4:52 pm #1562484

adriO

Arrgghhh, now my reply with image is visible.......

April 3, 2018 at 11:11 am #1563246

adriO

I took another look and no WPML Media plugin is available for download..........
What's going on?

April 4, 2018 at 9:07 am #1564505

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please download the media plugin from wpml.org/downloads and let me know if this helps?

Look forward to your reply.

Thanks

April 4, 2018 at 9:12 am #1564516

adriO

Like I said: there is NO WPML media version 2.3 for download available on that page.
Your attention please.....

See screenshot

April 4, 2018 at 9:23 am #1564536

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello, I am sorry I misunderstand it.

Actually to use the dev version you can use the latest versions of the plugins (including WPML Media) and discard the message for some time until the stable version is out. Could you please install the latest version and test it once?

Look forward to your reply.

Thanks

April 4, 2018 at 9:25 am #1564538

adriO

Thanks I will install it once more and give it a try. I will let you know.

April 4, 2018 at 10:02 am #1564582

adriO

That was quikcly done.
Remarks beforehand:
English -> Primary language
Dutch -> Secondary language

After installing the plugin I noticed:

1) The Dutch shop page appears to be empty.
2) Selecting a Dutch category shows the results expected.
3) Performing a search on a category name in Dutch show no results
4) Performing a search on an English category name on a Dutch page shows the results as expected
5) The same results as in 3 and 4 are shown when performing searches on product tags.

All in all, nothing changed or improved. It is still a mess.
I do hope you can work with it and can get the dev department into the highest gear.... 🙂

Best wishes,

Adri

April 4, 2018 at 10:11 am #1564596

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Do you have a live site or a staging site currently so we can debug this further?

Look forward to your reply.

Thanks

April 4, 2018 at 11:14 am #1564685

adriO

Hi Shekhar,

On november 27th 2017 you supplied instructions to send you a Duplicator package because I only have a local development version of the site. And I did send it to you. Did you read back the posts on this thread?
If needed I can supply you with a new one, just let me know.

April 5, 2018 at 10:15 am #1565798

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, I have those details back, I was asking if till now you have created a live site so we can work on there to get the results properly.

Since you are still using localhost, I will create a site on our test server and we will work further on it.

I have tested the same issue on the package you provided earlier and it's working for me, the only difference is I am testing it with the minimal installation of themes & plugins. So could you please test the issue on minimal installation (default themes and wpml plugins) once and let me know if this helps?

Also, could you please confirm if you are using the latest version of plugins of Relevanssi?

Look forward to your reply.

Thanks

April 6, 2018 at 4:27 am #1566713

adriO

I've tested it
Remarks beforehand:
English -> Primary language
Dutch -> Secondary language
Theme -> TwentyFifteen (only one installed)
Plugins -> Minimal set (see screenshot)

After installing the plugin I noticed:

1) The Dutch shop page appears to be empty.
2) Selecting a Dutch category in the pull down shows the results expected.
3) Performing a search on a category name in Dutch show no results
4) Performing a search on an English category name on a Dutch page shows the results as expected
5) The same results as in 3 and 4 are shown when performing searches on product tags.

So, the same results as with the last test........

April 6, 2018 at 9:34 am #1566948

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This seems unusual, to further debug this issue, I would request you to send me duplicator packages of your current setup, I tested this on a previous duplicator but it's working for me, so please send me the new duplicator packages.

I have enabled the private reply for you.

Thanks

April 9, 2018 at 9:55 am #1570195

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The reason why it seems it's not working for you is due to the fact that plugin hasn't created the indexes yet, so could you please go to Settings->relevanssi->indexing and click the "Build the Index" and index unindexed posts, this will solve the issue for you.

Also for the Dutch shop page, could you please go to Settings->Permalinks and hit save once? This should solve the issue for you.

Let me know if this helps.

Thanks

April 9, 2018 at 1:12 pm #1571208

adriO

Hi Shekhar, thank you for your reply.
Unfortunately your suggestions did not resolve my issues.
First: I did created an index before.

I tried it again and noticed that 47 posts were ignored.
Tried to index the unindexed posts but no avail. The posts were found but Relevanssi was not able to index them (waited for about 10 minutes.
I did re-saved the permalinks but that also was not solving anything.

As you can see in the screenshot a "nothing found" massage pops up (in Dutch of course) when I perform a search for "Dieren" (Dutch for animals) which is a category.

What to do next.....