This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 41 replies, has 3 voices.

Last updated by adriO 1 year, 2 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 10, 2018 at 9:56 am #1580317

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To make this debugging quicker I have created a test site with the duplicator package you provided and quite unusual is that I am unable to replicate the issue there, so could you please check your email follow the instructions there and see if you can replicate the problem on a live site?

Look forward to your reply.

Thanks

April 11, 2018 at 4:30 am #1589374

adriO

Hi Shekhar,
Thank you again for your reply and all the effort you put into this issue.
Unfortunately it is getting weirder and weirder on my end.

I tested it on the live debugging site and below are my findings (see also the screenshots).
1) No images are shown at all, only the placeholders.
2) The Dutch "shop" page appears to be empty. I checked the admin area and noticed that there is no message telling me that "fotos" is the shop page for Dutch. Or any other account page for that matter has a "WooCommerce message of what page it is.
3) The search problem appears to be the other way around at this moment. When searching for the category "dieren" (animals) in the Dutch site it shows all 10 results.
4) Searching on the word Animals in the English site gives me no results.
5) Searching on the word "dieren" (the Dutch word for Animals) in the English site gives me all 10 results.

Don't be tricked into thinking that the Dutch shop page is showing products. What you possibly see is the fallback option of WPML is kicking in. When clicking on the word Foto's in the header menu is showing you the real Dutch shop page (at least, this one should be the Dutch shop page)
If you see a page, filled with products, look at the page title. Does it really says 'Foto's"? Or does it says "Photos"? In the latter case it is the English version (fallback).

Deactivating the Relevanssi plugin "repairs" the search problem but NOT the empty Dutch shop page.

I'm really puzzled on how this can be happening.
I do hope I am clear enough to follow on and that you are seeing the same results as I am.

Good luck with it.

April 11, 2018 at 4:37 am #1589400

adriO

Is it really not related to the warning we are getting about WooCommerce Multilingual not being effective?

April 11, 2018 at 2:27 pm #1597669

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The photos are not showing as I have created the test site without uploads to make the size minimum.

I am currently discussing this issue with our developers and will respond to you soon.

Thanks

April 11, 2018 at 2:34 pm #1597819

adriO

No photos showing: understood.

I do hope you ar able to sort it out. I will try to be patient 🙂

April 23, 2018 at 6:26 am #1756767

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Shekhar is on vacation now. So I am taking care of this ticket. Hope it will be okay for you.

I will check with our compatibility team about this issue and get back to you soon. Please wait.

--
Thanks!

Bigul

April 27, 2018 at 5:48 am #1851228

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We have released a new version of WooCommerce Multilingual(4.2.10). Please upgrade to the latest version after a full site backup. Then rebuild the Relevanssi index once again after the translations(via WPML Translation Editor if it is missing) and check the issue is existing or not.

--
Thanks!

Bigul

May 2, 2018 at 6:57 am #1922013

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please let me know if the updated version helps to solve the issue.

Also, our 2nd tier supporter suggested that you should use translation management to translate the category in order to translate it properly, so could you please go to WooCommerce, WooCommerce Multilingual -> Category and translate those categories and let me know if this helps.

Thanks

May 3, 2018 at 8:48 am #1950987

adriO

@Bigul and @shekhar, thanks for replying.

Tried the suggestions you make to no avail. The problem is still exact the same.
I do hope you have an other real suggestions and no wild guesses.

Best wishes,

Adri

May 4, 2018 at 5:50 am #1968941

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have sent the feedback to our compatibility team and I will respond back to you soon.

Thanks

May 15, 2018 at 10:41 am #2135968

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please follow the below steps to fix the issue:
- Turn off WPML > Languages > Adjust IDs for multilingual functionality
- Re-build Relevanssi index
- Check if search results are correct

Let me know if this helps.

Thanks

May 16, 2018 at 6:33 am #2150077

adriO

Hi Shekhar,
That does the trick as it seems.
Although the search results are not quite right yet. The results are consistent in English as they are in Dutch. I have to dive in the results issue but that does not seem to be WPML related.

I only wonder, what benefits am I missing when the Auto Adjust ID's option is disabled? I can't imagine that you did put it there for no reason. Please explain....

Best wishes,

Adri