This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.60 hours from now. Thank you for your understanding.

Author Posts
March 28, 2019 at 3:13 pm #3482943

Patrick Cruz

I am trying to:

Get the completed translations. using WPML's Translation Jobs from SDL.

Link to a page where the issue can be seen:
hidden link

I expected to see:

A new page in EN-GB with the translated content.

Instead, I got:

an error.

No route was found matching the URL and request method

March 28, 2019 at 4:34 pm #3483915

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi and thanks for contacting our support forum.

Can you please go to WPML -> Translation Management, and click on "Check status and get translations" button, and see if this helps to get the completed translations.

Best Regards.

March 28, 2019 at 5:23 pm #3484385

Patrick Cruz

I get this error:

A communication error has appeared. Please wait a few minutes and try again.

March 28, 2019 at 7:52 pm #3485365

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for your reply.

Could you please provide me with temporary access (wp-admin and FTP) to your site in order to provide a better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

+ Please make sure that you have a full backup of your website and database. (Please don't ignore this)!

Best Regards.

April 2, 2019 at 5:34 pm #3519535

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

It seems that you have some corrupted data which make WPML not able to connect to our translation proxy and install the translation, so to be able to debug the problem I’d like to replicate your site locally. For this, you'll need to temporarily install a plugin called "Duplicator" on your site. This will allow you to create a copy of your site and your content. You can provide me with the snapshot following these directions:
If you already know how Duplicator works ( http://wordpress.org/plugins/duplicator/ ), please skip the following steps and just send me the installer file and the zipped package you downloaded.

:: Duplicator instructions
hidden link

Send me both files (you probably want to use DropBox, Google Drive, or similar services)
#Important:
As the snapshot file will be quite big, you can exclude the images if the file is very big, you can use the filters to exclude the uploads file and also use the filter to exclude any compressed files with these extensions .rar, .gz and .zip )

I will set the next reply as a private reply so you can provide a link to download the duplicator package.

Best regards

April 3, 2019 at 8:59 pm #3530435

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the package and sorry for the late reply, it took me a long time to be able to run your site locally, but finally, I tested it on my local server and the site downloaded the translation correctly without any issues, check the attached screenshots.

But on your site, when you try to get the translation, this link returns 404 error: hidden link
(please check the attached screenshot from your online site)
so I guess that your server is blocking our request, so can you please check with your server admin if they have any info about this, and I will check with our developers if they have any info about the reason for this.

Best regards

April 3, 2019 at 9:50 pm #3530567

Patrick Cruz

Thanks Ahmed for taking a look on this. I checked on our logs and there's no errors about this.

we're running on PHP7.3 and NGINX, do you think this can cause any issues?

our permalinks also removes the trailing slash.

also is that the correct url?

it looks like this one works: hidden link
without the /tp/apply-translations

Thanks.

April 4, 2019 at 5:25 pm #3537263

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I have checked with our developers, and they said that In TP logs we can see that we receive the request. The 404 error that you see in the console is a request sent to your site.

Our TP IP address is: 74.50.54.24.

We still guess that the issue is caused by your server settings so can you please check with your server company if they have anything that blocking our TP.

Can you also please update WPML plugins to the latest version, because it has some fixes that could help in your case.

Best regards

April 12, 2019 at 4:42 pm #3600643

Patrick Cruz

My issue is resolved now By using the automatic method. this works but using the button to do it doesn't.

This works: Translation Service will deliver translations automatically using XML-RPC

This Doesn't: The site will fetch translations manually

Thank you!