This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Otto 1 year ago.

Assigned support staff: Otto.

Author Posts
September 24, 2018 at 1:44 pm

matiasG-6

I had translate the homepage but the languages is not switching, I m using enfold theme and the flags are in the main menu but no in a dropdown menu and the languages is not switching.

Thanks

September 24, 2018 at 2:08 pm #2760720

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Please try the following:
Go to WPML > Soporte > Solución de problemas > and click in "Borrar caché en WPML" and "Desactivar caché para plantillas del selector de idiomas".

Also, as your site is hosted with Godaddy, you may need to apply this fix:
https://wpml.org/forums/topic/language-switcher-works-on-all-pages-except-home-pages/

Let me know if this helps, please.

Kind regards,

Otto

September 24, 2018 at 2:33 pm #2760786

matiasG-6

Thanks! now the switcher is working but i want to show in a dropdown mode.
who can i do?

September 24, 2018 at 2:45 pm #2760814

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I am glad it helped 🙂

The switcher that your site is showing is not from WPML but from the theme. So, in order to customize it, you need to ask Enfold support.

If you decide to use a language switcher from WPML, here you have how to set it and customize it:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Let me know if this points you in the right direction, please.

Kind regards,

Otto