Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 3 voices.

Last updated by Laura 4 months ago.

Assigned support staff: Laura.

Author Posts
June 27, 2019 at 2:51 pm

tobiasL-11

Ich nutze eine deutsche Seite mit englischer Übersetzung.
Ich habe ausschließliche deutsche Composite Produkte, bei dem als Komponenten Produkte und Kategorien in der deutschen Version eingebunden sind. Das klappt gut.
Weiterhin nutze ich aber auch ausschließlich englische Composite Produkte, bei denen ich als Komponenten Produkte und Kategorien in der englischen Übersetzung der deutschen Version eingebunden sind. Das dunktioniert nicht. Es wird immer die deutsche Version angezeigt.
Das ganze betrifft auch nur die Bestellungen.

June 27, 2019 at 8:45 pm #4102971

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

You have opened this ticket in the English forum but wrote your post in the German language.
If you would like to continue here then, please just reply back in English and ask your question again. If you prefer to get support in the German language then, please open a new ticket with this issue in our German forum here.
https://wpml.org/de/forums/forum/support-in-deutsch/
Or let me know and I'll pass this ticket to our German supporter.

Thanks,
Itamar.

June 28, 2019 at 7:55 am #4105283

tobiasL-11

Oh sorry:
I am using a German website with English translation.
I have exclusively German composite products, where as components products and categories are included in the German version. This is working well.
Furthermore, I also use exclusively English composite products, where I used as component products and categories the English translation of the German versions. This doesn't work. The German version is always displayed.
The whole thing concerns also only the orders

June 30, 2019 at 2:00 pm #4114257

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for replying in English.

Is the issue that you have concerns the Composite Products plugin?
https://woocommerce.com/products/composite-products/

Could, please as the first step debugging the issue update WordPress and WPML and its add-ons and see if the problem persists?
I can see that WordPress itself and WPML + String Translation + Translation Management are not updated on your site. So please update the above and any related plugin as the Composite Products product.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

July 1, 2019 at 9:18 am #4116883

tobiasL-11

Hello Itamar,

I updated all plugins but the problem presists.
Unfortuantely I can't debug this becasue I need the composite product to be active. The problem only only in the combiantion of wpml and composite.

Best wishes
Franziska

July 1, 2019 at 3:15 pm #4120599

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Franziska,

since Itamar is off this week I'll take care of your ticket.
Could you please send me a link where I can see the issue?

Also, would it be possible for you to do this compatibility test? it's not clear from your last post if you tried something similar or not.
- backup your site
- disable all plugin except WPML and its addons, WooCommerce and Composite Products
- switch to a default theme like TwentySeventeen
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again
- lastly, reactivate your theme

July 3, 2019 at 1:31 pm #4137003

tobiasL-11

Hello,
unfortunately debugging like this isn't that easy because the content of the composite products is only shown when our custom theme is activated.
So I tested with out theme activted but only the plugins active you mentioned.
the problem still presists.

July 4, 2019 at 8:00 am #4140973

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Franziska,

so there is a chance that the issue is with your theme, not specifically with the plugin Composite Product. If this is the case, I'm not sure to what extent we can help you since we do not support custom themes.

Anyway, I'd ask you to reproduce the issue here (with your theme too) so I can do further tests and determine what is causing the issue: hidden link

July 4, 2019 at 9:16 am #4141803

tobiasL-11

Hello Laura,

I managed to reproduce the problem with thr standad theme. here is the order:
hidden link
Can you set the conversation to private so I can send you the login?

July 4, 2019 at 12:16 pm #4143091

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Franziska,

thank you, I'll enable a private reply.

July 4, 2019 at 12:18 pm #4143103

tobiasL-11

Here are the credentials:
[removed]

July 4, 2019 at 3:37 pm #4145141

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

thanks for reproducing the issue. I'm not sure why, but the credentials were exposed so I removed them.

I'm not sure what I should see with the page you linked me. You said composite products are always displaying in German even on the English website, but the page you sent me is an order summary.

How do I find a composite product in the front end?

July 8, 2019 at 10:36 am #4161341

tobiasL-11

Hey Laura,

the problem is in the order and not in the product. The product gets shown correctly in the frontend. But in the order the languages are mixed up.
The corespondig product is this one: hidden link

July 8, 2019 at 3:43 pm #4164099

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

so the issue happens only in English? I'm not sure if this isn't an expected behavior but I cannot complete order in German, it keeps saying I need to choose a shipping method but I don't have the option to do so.

If the problem happens in German too, could you try to disable WPML and see what happens?

July 18, 2019 at 11:58 am #4238349

tobiasL-11

Yes, the problem appears only with orders in english.
Your can use the voucher code "pickup" for free delivery.

The topic ‘[Closed] no translation within composite products in orders’ is closed to new replies.