Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 3 voices.

Last updated by Laura 4 months ago.

Assigned support staff: Laura.

Author Posts
July 18, 2019 at 12:27 pm #4238687

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Can you please readd the credentials in the private reply? Since they were exposed I deleted them and I didn't save them.

July 24, 2019 at 2:07 pm
July 25, 2019 at 7:52 am #4280337

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Franziska,

thanks for the credentials.

I did some tests but I'm still not sure what is the issue here.
I placed an order in German, and it seems the same as the one you linked me as an example of the issue.
Please check screenshot orderDE and orderEN.

So I even tried to deactivate WPML and place a new order (in German, since it's the default language) but the product composition still seems the same to me. Please check screenshot nowpml.

Am I missing something here? What do you expect to see?

July 29, 2019 at 9:37 am #4298259

tobiasL-11

hmm it's stange it's working for you (orderEN). Because when I try it it doesnt work.
Here my test order and screenshot: hidden link

But what I noticed is, that the language mix doesn't appear in the order confirmation e-mail of the customer. There it's correct (see image attached).

Usually I would say: Ok, that's all that count's bit the problem is that we create invoices from the order in the backend and because in the backend the languages are mixed they also appear like this on the onvoice.

July 29, 2019 at 1:34 pm #4300231

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Franziska,

from your debug information I see the admin language is German. Can you try to switch to English and see if you get the same results like mine? It shouldn't work like that but at least we'll know what to look at.

August 6, 2019 at 1:45 pm #4347995

tobiasL-11

somehow my anser disappeared. Very sad... Yes I can confirm that this is solving the problem for the moment, but it's no solution, because we have to use the german language.

August 7, 2019 at 7:47 am #4352543

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Franziska,

yes, I can understand you need to use German, and it shouldn't work that way.

The compatibility team should take a look at this issue, but to do so, I really need to reproduce in a fresh installation.

I created a Sandbox for you: hidden link
Please configure WPML as it is on your site and install the plugin for Composite Products.
Then please create some options (it shouldn't be identical to your site - 1 composite product with a couple of options will do)

If you have problems displaying the products on the front end I'll try to do it.
Once we can reproduce the problem, I'll send it to the compatibility team.

The topic ‘[Closed] no translation within composite products in orders’ is closed to new replies.