This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 4 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 22, 2019 at 1:08 pm

chloeR-2

I am trying to: switch to french but no translations are found. I didn't change anything on the plugin it just stopped working from one day to the other. All the articles are translated but not anymore and the menu is now in 2 languages.

Link to a page where the issue can be seen:
hidden link

I expected to see:
hidden link

Instead, I got:
No translations.

May 23, 2019 at 12:56 am #3870069

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a closer look in your WordPress Dashboard and indeed there's no translations for pages or menus. Can you please confirm if some event occured as the cause of the missing translations, for example some third party plugin activation and updates? Do you have any backup copy of your website? Is it possible to see any translation in your database icl_ tables? Please, let me know these details. Have a nice day.

May 23, 2019 at 10:03 am #3873261

chloeR-2

Can you please confirm if some event occured as the cause of the missing translations, for example some third party plugin activation and updates?
-> If something happens I don't know what and I don't remember having done something and then notice that there are no translations anymore.
I had a look at the table and yes I can see some translations:
hidden link
I think you have access to the database in the backup I've sent. If it's not the case let me know and I can give you access

May 23, 2019 at 5:45 pm #3878431

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, provide me with some database management access such as your host cpanel or any other route to access the database managment tool of your host. It is required so I can take a detailed look at the WPML tables in order to understand the cause of your issue, a private reply is enabled for you again, so you safely send these details. Thank you for your collaboration, have a nice day.

May 23, 2019 at 6:22 pm
May 26, 2019 at 2:51 pm #3891849

chloeR-2

Hello! Did you see my private message?

May 28, 2019 at 1:51 am #3901843

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details and sorry for the waiting here due the weekend. I took a look in your database and the translations seem to be properly on place. I will proceed the investigation process with a duplicator package of your website, for that, please make sure to provide us with a full duplicator package, here are the details on how to proceed: To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

I will update you here as soon as I have some more details. Thank you for your continued patience and understanding, have a nice day.

May 28, 2019 at 7:01 am
May 28, 2019 at 5:23 pm #3909031

chloeR-2

The french translation is there but displayed in english
hidden link

May 31, 2019 at 1:13 am #3926887

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details and sorry for the bit of waiting here. I took a look a detailed look in your website using the provided duplicator package and noticed while in your archived website hidden link the default language is defined as French, your production site has English as the default language.

It seems something/someone accidentally changed that and this way all the translation were gone. Do you have any saved backup copy of a previous state? It should be the easier and maybe the only method of restoring your website here. Please, let me know, have a nice day.

The topic ‘[Closed] No translations displayed in french’ is closed to new replies.