This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by janF-6 1 year, 4 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 17, 2018 at 12:43 pm

janF-6

I am trying to: Access WPML settings

Link to a page where the issue can be seen:

sandbox.falcontailor.com

I expected to see:

Instead, I got:
"Sorry, you are not allowed to access this page."

This happens to 2 Admin users, of which I just created a new one; abuzer.cs@gmail.com and thecodezel@gmail.com. I can see it from my user; mail@falke.org.

NB! I had the exact problem in JUNE 17, 2017.
https://wpml.org/forums/topic/no-wpml-icon-in-dashboard-and-sorry-you-are-not-allowed-to-access-this-page/
And your support, Joanna solved it for me. Could you please have a look and see if you can do the same?

Kind regards
Jan

May 17, 2018 at 2:10 pm #2177296

janF-6

Just added a screenshot

May 18, 2018 at 3:55 pm #2190272

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Jan,

Welcome to WPML support forum.

Please apologize for the delay in answering. This is not usual in this forum. While one of my teammates takes care of your case I will provide you with the first debugging steps.

- Make a full backup of your site.
- Add this code on your functions.php file:

function wpmlsupp_1706_reset_wpml_capabilities() {
    if ( function_exists( 'icl_enable_capabilities' ) ) {
        icl_enable_capabilities();
    }
}
add_action( 'shutdown', 'wpmlsupp_1706_reset_wpml_capabilities' );

- Visit your front-end.
- Remove the code

Let us know if it helps.
Andrés

May 18, 2018 at 7:26 pm #2191577

janF-6

Hello Andrés, thanks. We have tried it but, it didn't work, sorry.

May 21, 2018 at 9:29 am #2200075

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I will be taking care of this issue further.

The steps mentioned by Andres should have fixed the issue, and since you mentioned it's not working, to further debug this issue, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

May 21, 2018 at 9:43 am
May 21, 2018 at 10:36 am #2200506

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see the language settings page without any issues. So could you please check it once more?

I can see that you are using an outdated version of WPML plugins and WooCommerce Plugin, could you please update the plugin to the latest version and let me know if that helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Look forward to your reply.

Thanks

May 21, 2018 at 11:26 am #2200785

janF-6

Hello, it helped to update the plugins!
Thank you very much for your help! Very much appreciated!