Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Ahmed Ibrahim 3 years, 5 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
February 8, 2017 at 6:02 pm #1203335

Karl

I am trying to:

When we add new pages to English menu on WMPL site, it automatically adds it as parent menu item in the other languages. But when I look at the menu's of the concerned languages they are not present there.

hidden link
'cold brew' and 'widget-technology' items should not be visible here.

URL of (my) website where problem appears: hidden link

February 9, 2017 at 2:40 pm #1204219

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for contacting the WPML support. We are happy to help you.

Please let me know the following for tracking the issue.

1) Does it happen after the recent upgrade of WPML?

2) Hope you are selected *Automatically add new top-level pages to this menu* option of Menu settings. Please confirm.

3) Have you changed the default/primary language before

4) Hope you haven't translated the *Cold brew* and *widget technology* pages yet

I have following requests. Please do it after a full site backup for the better performance.

1) Please upgrade to the latest version of WordPress(4.7.2)

2) Please upgrade MySQL to 5.6. The minimum required MySQL version for WPML. Check this article for more details -- https://wpml.org/home/minimum-requirements/

3) Increase *WP Memory Limit* to *128*(the required memory limit for WPML). Please check the following link for more details

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

4) Increase *MaxInputVars* to *5000* or more

--
With Regards
Bigul

February 9, 2017 at 4:17 pm #1204359

Karl

1. I can't tell, we noticed when we added new pages to the site; we hadn't done so for a long time

2. "Hope you are selected" I think you mean "deselected"

3. primary language is not changed

4. pages are not translated

-------------------

I have upgraded all other things conform your requests.

February 10, 2017 at 9:59 am #1204904

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the updates. I would like to know you have selected *Automatically add new top-level pages to this menu* option of Appearnce>>Menu settings or not. Please confirm.

It would be nice if you can provide me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

After enabling debug log, please create a New page in English and confirm it is adding to the Dutch/German Menu.

--
With Regards

Bigul

February 13, 2017 at 8:23 pm #1207254

Karl

Hi Bigul

I have NOT selected 'Automatically add new top-level pages to this menu'

http://pastebin.com/raw/vVBZgQb7

February 14, 2017 at 8:28 am #1207517

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for the updates. Please let me know have you reproduce the issue while creating a New page(for test) in English.

I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup. Check the following links for more details about private information sharing.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue locally.

--
With Regards

Bigul

February 15, 2017 at 8:38 am #1208666

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the login details. I have downloaded your duplicator package now. Will debug it as soon as possible and update you. Please wait.

--
With Regards

Bigul

February 16, 2017 at 11:09 am #1209943

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

For your kind information, I am unable to produce the issue on my local with your duplicator copy. I have added few Pages in English, but none of them is added to Dutch menu. Please check the attached images for more details.

Therefore I have a request, please create a New page in English and make sure it is adding to the Dutch/German Menu. Also, let me know the detail instructions(for reproducing the bug) to confirm in case I am missing something.

--
With Regards

Bigul

February 16, 2017 at 11:15 am #1209955

Karl

hi

I just have added a page with name 'debug' in English and put under parent menu 'Innovations'. As you can see it appears now in Dutch and German language as parent menu.

February 17, 2017 at 1:25 pm #1211115

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the details. I can replicate the issue in my local now. It looks like a compatibility issue between WPML and Max Mega Menu plugin. The same problem is not happening to me when Max Mega Menu is inactive. But I am unable to replicate the issue in a fresh installation with WPML, Max Mega Menu, and Genesis themes.

Therefore I have forwarded the details to our second tier team and waiting for their feedback. Please wait.

--
With Regards

Bigul

February 22, 2017 at 3:18 pm #1214791

Karl

any progress on this?

February 23, 2017 at 7:44 am #1215235

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Sorry for the delay. We are still debugging the issue and it is unable to replicate in a fresh installation after several tries. Therefore I am escalating the ticket to our Second tier team.

We will get back to you as early as possible. Thank you for your patience. Please wait.

--
With Regards

Bigul

February 28, 2017 at 3:08 pm #1219118

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, this is Ahmed Ibrahim from the second tier team.

I can see the issue, I have replicated it with the "debug" page as you did on your online site, but I have noticed that the "debug" page is not translated at all, so after translating it to the two languages, and then go to WPML -> WP Menus Sync, then sync the menu, the debug page has disappeared from the secondary languages menu and instead the translated pages appear correctly under the "Innovations" menu, so have you tried to translate this page and then sync the menu and test again, are you managing to add some not translated pages to the default language?

Best Regards.

The topic ‘[Closed] non translated items being added to menu structure if not translated’ is closed to new replies.