This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Marcos Vinicios Barreto 7 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 20, 2019 at 10:40 pm #3393869

pareshJ-2

I am trying to:

Link to a page where the issue can be seen:
hidden link

I expected to see:
hidden link
Instead, I got:
Page Not FOund.

I have not enabled Italian, so it works correctly if I do this:
hidden link
Only language that is enabled in WPML config besides default English is Japanese.
So, far I have only translated one page in Japanese and that works file
hidden link

March 21, 2019 at 3:15 am #3394987

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It happens because the about page is not yet translated, as you have your Japanese language enabled you will see a 404 error. If you need to display unstranslated content and avoid such kind of issue, you can proceed this way:

1 - In your WordPress Dashboard > WPML > Settings > Post Types Translation choose the option 'Translatable - use translation if available or fallback to default language' for the 'page' post type.

See: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

Please, let me know if it helps. Have a nice day.