This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Diego Pereira 8 months ago.

Assigned support staff: Diego Pereira.

Author Posts
February 14, 2019 at 5:12 am

avinashG-2

I am trying to: Edit page using elementor or edit woocommerce product page

Link to a page where the issue can be seen: Any product page/ or normal page

I expected to see: Should be able to edit page for other languages after activating WPML

Instead, I got: Instead I am not am not to edit page

February 14, 2019 at 3:36 pm #3200703

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @avinashg-2, welcome to the WPML support Forum!

Could you please elaborate a little more on this issue, so I can better understand? E.g. The link of the page, steps you've tried, etc.

Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

Please also enable WP_DEBUG on your website to check if it displays a error message and more details about the error. If so, please send us a screenshot: https://wpml.org/documentation/support/debugging-wpml/

All the best,
Diego

February 15, 2019 at 5:41 am #3202863

avinashG-2

I am trying to edit page after enabling WPML and getting error. Attached is screenshot for the same. Login as a admin and go to homepage. click on Edit option and see what error you get. When I disable WPML, I am able to edit page.

February 15, 2019 at 5:32 pm #3206192

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Have you enabled the wp_debug and wp_debug_log? Could you please check if there is any related errors added to the log? It's generated on the /wp-content/ folder of your website.

A 500 error means that there is an error in the PHP code that your site runs. See more details and how to solve the issue here: https://wpml.org/faq/500-error/

I also checked the settings of your server through debug log and saw that some items need attention:
PHP version
Upgrade the PHP to version 7 or higher. This is a practice recommended by the WordPress.org website: https://wordpress.org/about/requirements/

Increase WP memory
If possible, please increase the PHP memory limit to 512mb.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Kind regards,
Diego