Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Otto 2 years, 1 month ago.

Assigned support staff: Otto.

Author Posts
June 19, 2018 at 7:37 am #2420971

heidiS-4

Tell us what you are trying to do? We have 6 WordPress pages where SEO didn't get translated. We use Yoast SEO.

Is there any documentation that you are following? WPML documentation

Is there a similar example that we can see?
What is the link to your site?
hidden link
This is a test install which is an exact clone of the production site

June 19, 2018 at 7:44 am #2420981

heidiS-4

(edited)

June 19, 2018 at 10:37 am #2421514

srdjan

Hello Heidi,
please do not post site credentials in public comment.
Use private reply, I set next one to be private.

Also please check credentials, since I cannot log with ones you previously posted.

Did you try to set SEO texts as described here?
https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/#translation-of-page-seo-attributes

June 19, 2018 at 10:00 pm #2423320

heidiS-4

Shared with you login credentials and sftp access. Please let me know if you didn't receive it.

June 20, 2018 at 8:15 am #2423714

heidiS-4

(edited)

June 22, 2018 at 10:25 am #2429140

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Heidi,

Please apologize for the delay.

Srdjan is off, so if you don't mind I will take care of this ticket.

Credentials were exposed and are not working for me.

I suggest you change them and can you please share new ones in the private box I enabled for your next reply?

Do not post private information in a regular post please, as it will be exposed.

Thanks!

Kind regards,

Otto

June 25, 2018 at 12:06 am #2431658

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Heidi,

Could you please update WPML and its add-ons to the latest version if the issue persists? Before doing it, please create a reliable backup of your site.

If this does not solve the issue, is it ok if I make a copy of the site to debug locally?

Let me know your results, please.

Kind regards,

Otto

June 28, 2018 at 11:14 pm #2442931

heidiS-4

I updated all plugins but the SEO copy still doesn't get translated. Feel free to make a copy of the site.

June 29, 2018 at 1:12 pm #2445908

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Heidi,

Thanks.

The problem is that the WP SEO fields are set to copy and locked.

If you go to edit a page, got to the bottom:
Multilingual Content Setup section > Custom fields > click on Show system fields, you will see that the fields:
_yoast_wpseo_title
_yoast_wpseo_metadesc
_yoast_wpseo_focuskw

are set to copy, and the fields are locked.

If you check the wpml-config.xml files inside the WP SEO plugins (free and premium), they are set to "translate". So there must be another wpml-config.xml file changing this behavior.

I added those fields again to translate in WPML > Settings > Custom XML config and also in WPML > Settings > Multilingual content setup > Custom fields (show system fields), I clicked on the lock to unlock the field. Set it to translate and the change reverts.

Somethings seems to be broken and the change is not saved. Maybe because there are too many custom fields options.

The Duplicator plugin is not working on WPEngine, so can you provide me with the DB and wp-content (excluding uploads) folder of the site so I can clone your site to debug locally? Please share a download link to the files. The

Meanwhile, you can do this test on your end:

***Backup your site and DB before proceeding***

-Deactivate all the plugins but WPML and its addons, keep also WP SEO
-Switch to a default WP theme (Twenty Sixteen for example)
-Go to WPML > Settings > Multilingual content setup > Custom fields (show system fields)
-Change the fields
_yoast_wpseo_title
_yoast_wpseo_metadesc
_yoast_wpseo_focuskw

to translate.
You will have to click on the lock first.

Does the change remains or it reverts? If it remains, are you able to translate the SEO fields now?

Let me know your results, please.

Kind regards,

Otto

July 8, 2018 at 6:18 pm #2474233

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Heidi,

I get the files to reproduce the site locally by mail. Thanks!

Locally I did the following test:
-Deactivate all the plugins but WPML (including the MU plugins) and its add-ons, and both SEO plugins
-Switch to a default WP theme (Twenty Sixteen for example)
-Then I manage to set the SEO fields to "translate" following these steps:
--Go to WPML > Settings > Multilingual content setup > Custom fields
--Click on show system fields
--Search for these fields:
_yoast_wpseo_title
_yoast_wpseo_bctitle
_yoast_wpseo_metadesc
_yoast_wpseo_metakeywords
--Then click on the lock to unlock the field. Set it to translate.
-In this scenario (just the related plugins and a default WP theme) the changes where applied and I can see the SEO fields when translating a page

Can you please try it in your site? If you manage to do the changes then reactivate all the plugins and the custom theme.

Let me know your results, please.

Kind regards,

Otto

The topic ‘[Closed] Not able to translate SEO’ is closed to new replies.