Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Not all pages can be translated with visual composer

Solution: https://wpml.org/forums/topic/not-all-pages-can-be-translated-with-visual-composer/#post-2784116

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.57 hours from now. Thank you for your understanding.

This topic contains 15 replies, has 2 voices.

Last updated by karenK-9 1 year, 8 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 2, 2018 at 5:43 am #2780362

karenK-9

Hi,

This is the only WP plugin that makes me crazy every time I try to use 🙁

Please help me.

hidden link

thanks

October 2, 2018 at 5:46 am #2780366

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Since we only take one issue per thread, I am separating this ticket from your previous ticket, this will make users with similar problem search the solutions in future easily.

Please follow the below steps and let me know if this helps:

1) Make the translation as complete (100%)

2) Now go to default language and update the post.

3) Send the post to translation again, this should show all the updated items.

Note: If the steps above don't work, I request you to add something dummy text on the default language and update the post on Step #2 and let me know if the items are showing or not.

Let me know if this helps.

Thanks

October 2, 2018 at 5:47 am #2780370

karenK-9

did you watch the video? please watch it again and again while you see that I can't translate separate text modules.

October 2, 2018 at 6:06 am #2780383

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, I watched and understand that what you are trying to achieve. Since the text modules are not being separated right now, I request you to follow the above steps, this should make sure to separate those modules while you are trying to translate again. You can just copy the current fields to translation and mark it as 100% complete.

Thanks

October 2, 2018 at 6:07 am #2780384

karenK-9

I am sorry I dont understand you. you have the access to my site. please try yourself. I would apreciate the video from you

October 2, 2018 at 6:42 am #2780473

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am sorry to let you know that I mistakenly deleted the homepage, could you please restore a backup of it so I can help further?

I was trying to delete the translation of the page but I didn't notice, "When deleting a post, delete translations as well" is enabled.

Look forward to your reply.

Thanks

October 2, 2018 at 6:48 am #2780475

karenK-9

done

October 2, 2018 at 10:57 am #2781161

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It seems the site is no longer reachable, could you please check it once?

Enabled the private reply, so if you want to send updated or new details send me in the next reply.

Look forward to your reply.

Thanks

October 2, 2018 at 9:37 pm #2782906

karenK-9

the site is working for me. please clear the cache

October 3, 2018 at 4:15 am #2783489

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I tried to create a duplicator package to debug this issue further, but it seems the duplicator is created for the main site, so to further debug this issue, please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

Enabled the private reply for you.

Thanks

October 3, 2018 at 9:59 am #2784116

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The shortcodes created by the plugin wasn't being registered as a reason the issue was happening, to fix the issue, please follow the below steps:

1) Copy the following code in WPML-> Settings -> Custom XML configuration

<wpml-config>
	<shortcodes>
        <shortcode>
            <tag>nd_options_text</tag>
            <attributes>
                <attribute>nd_options_text</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>nd_options_button</tag>
            <attributes>
                <attribute type="link" encoding="vc_link">nd_options_link</attribute>
            </attributes>
        </shortcode>
</shortcodes>
</wpml-config>

2) Once you place the code there, go to WPML->Settings -> Multilingual content setup and refresh the page.

To find out more, https://wpml.org/documentation/support/language-configuration-files/

Once you have created language configuration files update both languages page.

Let me know if this helps.

Thanks

October 3, 2018 at 5:37 pm #2785404

karenK-9

Hi.

I did. Three questions.

1. After refreshing I dont see the code I pasted in the Custom XML any more
2. Why the plugin wasn't being registered?
2. I tried but it didn't work for homepage.

October 4, 2018 at 3:57 am #2786394

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

1. After refreshing I dont see the code I pasted in the Custom XML any more

I added and I can see the code in the section without any issues

2. Why the plugin wasn't being registered?

Not the plugin, but the shortcodes created from plugin weren't registered properly. This happens because each plugin use different shortcodes format and to register it we will need different config files accordingly.

I just tried myself and the homepage is translating without any issues, so could you please check.

Thanks

October 5, 2018 at 12:00 am #2788961

karenK-9

It's weird. now it works.
anyway we made some changes, restore some backups and installed a plugin so I am thinking maybe to restore to copy without the WPML plugin and start from Scratch using your recommendation.
I hope I wont have any issues.

thanks

October 5, 2018 at 5:45 am #2789574

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sure, I don't think it will have issues, let me know if you still need help.

Thanks