Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Translation missing images and footer text not translatable and WPBakery Row Heading not translated

Solution: Before translating a post or pages make sure to mark the Media Attachment settings for duplicating the media files. The footer text has been translated after adding the string from String Translation option "translate texts in admin screens" The WPBakery row settings been translatable after adding a custom XML config for the row settings title.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/media-translation/ https://wpml.org/documentation/getting-started-guide/string-translation/ https://wpml.org/documentation/support/language-configuration-files/

This topic contains 22 replies, has 2 voices.

Last updated by sabrenaS 7 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
March 26, 2019 at 5:20 pm #3465133

sabrenaS

Hi Andreas,

I was able to translate the contact forms, I just have to work on the validation text which looks like it uses PHP. I was also able to find the footer string and send that fro translation thank you!

For the events, I was able to get them translatable after altering some settings but I am only seeing the events in the manual translation area: WMPL > Translations
but I cannot make them selectable in the Tranlsation Manager so I can send them to the tranlsation service. When I try to select and type other than "Page" here it just resets to display only pages.

Do I manually have to translate events or am I missing a setting somewhere that will allow me to send them to the translation service? Thanks!

March 26, 2019 at 5:54 pm #3465353

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I connected to the website and went to Translation Management. I selected the filter Events and clicked on "Filter" to apply the changes. The first request some flipped back to "Pages" but after selecting the filter again it changed to Events.

I am not sure why it is behaving like this. It might be a memory issue.

Could you please increase your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 128M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Then please try to translate an Event with Translation Management and let me know if you experienced any difficulties.

Kind regards
Andreas

March 26, 2019 at 8:17 pm #3466223

sabrenaS

Hi Andreas,

I've increased memory to 256m but I still cannot get it to show anything other than pages in Translation Manager. I even tried it in different browsers but no matter what I tried I could not get that to stick, it always reverts back to only Pages.

March 27, 2019 at 2:32 pm #3472011

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

From my last inspection today I can tell that while taking 10 attempts selecting the filter it flipped back to "pages "once once. this might be caused due to server issues.

I am consulting our second tier about the issue and I will get back to you after I received feedback.

I will let you know about the outcome.

Kind regards
Andreas

March 27, 2019 at 3:40 pm #3472939
sabrenaS

Thank you. I only had one other issue you can look at while we wait to hear back. On the Home page and the Careers pages, we use a Visual Composer created Post Grid. On the French version it is not displaying the images just showing a placeholder. I have uploaded images of both the English and French version.

I went into the posts to make sure that the media checkboxes were checked, but I have no way of selecting them to update. This might be due to the previous issue. Thanks

New threads created by Andreas W. and linked to this one are listed below:

https://wpml.org/forums/topic/split-vc-post-grid-does-not-translate-images/

March 27, 2019 at 6:20 pm #3474747

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

In regards to the latest request I have opened a new ticket and I will be replying on this thread late today. This methods will help other clients to find a solution for similar issues.

About the issue with the filter on Media Translation it would be helpful if you could provide information from the debug.log file.
In order to obtain this information please follow those steps:

WordPress includes a debug mode which helps reveal PHP problems.

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
In order to enable the error logging to a file on the server you need to add yet one more similar line:

define( 'WP_DEBUG_LOG', true );
In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

define( 'WP_DEBUG_DISPLAY', true );
The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */
Please note that you’ll see everything, not only related to WPML. This will most likely include messages from other plugins, your theme and sometimes even WordPress core. The messages appear all over the place. Sometimes they appear right on top, but they can also appear in the middle of the page.

Kind regards
Andreas

March 28, 2019 at 5:51 pm #3484609

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your messages.

The issue about setting the Translation Management Content Filter has been escalated to our developer team who will work on a fix. The next update for our Translation Management Plugin should be able to solve the problem.

Kind regards
Andreas

April 13, 2019 at 8:29 pm #3605615

sabrenaS

My issue is resolved now. The latest update of WPML fixed the issue where I could not select any other than pages in the translation manager. I found another unrelated issue so I created a separate ticket. Big thanks to Andreas for his patience and excellent help in fixing all of my issues!