This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 25, 2019 at 5:09 pm #4285333

manuelC-26

I am trying to: In the portuguese version of the website, in each product page, we see 5 images of the product, but in the english version there is only one.

Link to a page where the issue can be seen: All product pages

I expected to see: The images have to be uploaded on the translated page or there is anyway to syncronize this images from the portuguese version to the english version?

Instead, I got:

July 25, 2019 at 5:27 pm #4285371

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 30, 2019 at 3:00 pm #4308897

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. It seems you forgot to provide a WordPress Dashboard access as well, I only see the FTP ones. Could you please review it? A private reply is now enabled for you again, so you can safely resend these access details. Thank you for your collaboration, have a nice day.

July 31, 2019 at 7:47 pm #4317455

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I still don't see the WordPress Dashboard access details, please, make sure to follow our instructions on how to provide these access, it will help us to optimize our support efforts and provide you with a solution in the shorter time possible. Thank you for your collaboration, have a nice day.

August 6, 2019 at 6:57 pm #4350089

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and could confirm the issue. Please, try the following:

1 - Make sure you have installed the WPML Media Translation addon (you can download it from your wpml.org account or right in your plugin settings in the commercial tab from the plugin installation screen).

2 - Now in your WordPress Dashboard > WPML > Settings > Media Translation make sure you have all the options checked and click the blue 'start' button, wait for the whole process to complete and check your translated product page again.

See: https://wpml.org/documentation/getting-started-guide/media-translation/

Please, let me know if it helps of if you need any additional clarifications and instructions, have a nice day.

August 7, 2019 at 1:34 pm #4355489

manuelC-26

Hi, I took all the steps you told me but the product images aren't on the product page yet. What should I do next?

August 7, 2019 at 5:22 pm #4357137

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

August 12, 2019 at 4:42 pm #4382427

manuelC-26

Hi, the migration of the website is now complete. Can you please take a look to find the issue regarding images?
Thank you

August 12, 2019 at 8:09 pm #4383521

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your website and noticed the issue happens due the custom fields translation preferences for your 'WooCommerce Additional Variation Images' plugin, here is how to proceed:

1 - In your WordPress Dashboard > WPML > Settings > Custom Fields Translation click to show the system fields and then set the field '_wc_additional_variation_images' as 'copy' and save your settings (see attached screenshot).

2 - Now edit your products in the default language and save them, make a minor editing such as adding a period, empty space, etc and click the update button for every product, update your translations to be 100% complete and you should be done. This action will make sure the database will be updated with your new translation preferences for the images variations custom fields.

Tip: You can add a period in the description field of every image variation, save the changes and update the post in the default language as manner of refresh the database tables with these new translation preferences for the images variations custom fields.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if it helps, have a nice day.

August 14, 2019 at 9:29 am #4393713

manuelC-26

Hi Marcos,

I proceed as you told me and the issue remains unsolved.. I took the steps and I did get the new images to translate, however the don't show up on the product page:
hidden link
hidden link

Or maybe because the product variations disappeared, an issue I was already having and under investigation: https://wpml.org/forums/topic/product-variations-not-ok/

August 14, 2019 at 6:51 pm #4397087

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. It happens because your translated product don't allow to choose a 'size' variation. For example, in your default language product at: hidden link if you don't chose a 'size' variation you will notice no images variations will be showed. Please, make a test with a translated products you have all the variations available and let me know. Have a nice day.