This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by hooiC 4 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
March 10, 2019 at 12:06 pm #3304125

hooiC

I am trying to: This is urgent as we are launching this week . On all the language sites , directing/navigating to VIEW CART or CHECKOUT pages is NOT working. you will find both links on the CART symbol right at the top of menu after adding an item to purchase.
VIEW CART: I noticed the url link(hidden link) for German works. However, if you look at Italy url link(hidden link) - it says no stock in cart. this is an issue for all the other languages(spain, french , dutch). is the url wrong or the stock is not recognised? similarly when you click on CHECKOUT symbol on CART, it does not direct to checkout page. for eg Germany, click on Kasse(on the cart symbol), you can see the url is "hidden link but can't get to this link. is there a quick way of fixing this issue via troubleshooting page?

I have tried disabling and enabling plugins and nothing works.
Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got:

March 11, 2019 at 10:23 am #3309703

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see the issue on your site. When I go to the Italian shop page here hidden link and add a product to the cart and then go to the cart, I can see that it is empty.

Here a few things that I would like you to check, please.

A. Make sure that the option 'Store a language cookie to support language filtering for AJAX' in WPML -> Languages -> Language filtering for AJAX operations is selected.
If it is not selected, then please select it and see if it solves the issue.

B. I can see that all the following related plugins are not updated on your site.
WPML, String Translation, Translation Management, WooCommerce, and WordPress itself.
Please update everything and check if the issue persists.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

C. You are using the W3 Total Cache plugin. Using a cache plugin is a great way to make your site's performance better. But the W3 Total Cache plugin is a very complexed plugin. Please make sure that one of its settings is not causing this issue. You can also check this by deactivating the W3TC plugin and see if the issue persists. Please read more about how to work with PWML and the W3TC plugin in our documentation here.
https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/

Regards,
Itamar.

March 11, 2019 at 1:42 pm #3313187

hooiC

Hi Itamar a) was already enabled. We did b) and c) together (by mistake_ and the problem has been resolved . I will leave this ticket open in case we need your assistance on the w3 total cache if we install this back later. by the way, how I get you as my support in future. can I select you when raising a ticket?

March 11, 2019 at 2:05 pm #3313479

hooiC

Hi Itamar the links on the footer is not working for all the language sites. Links under Terms of Use | Privacy Policy | Cookie Policy do not direct to the translated page. its directed to the English page

English is our primary language and Irish is a duplicate of English
are you able to help me with this issue? if you want me to raise this a separate ticket but how do I ensure you support us on this? its an urgent request. thank you

March 11, 2019 at 2:55 pm #3313945

hooiC

Hi Itamar are you able to assist me with my query? thank you

March 12, 2019 at 11:48 am #3321751

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm glad that the initial issue of this ticket is resolved now. I'll wait to hear from you in case something goes wrong again with this issue.

About your other question, please continue to handle it in the ticket that Alejandro my teammate is handling here.
https://wpml.org/forums/topic/url-in-widget-per-language-not-redirecting-to-page/

Thanks,
Itamar.

April 10, 2019 at 7:09 am #3572969

hooiC

Hi Itamar, this is an urgent request. we have now put the language on the production (live) site and experienced lots of issues ie missing styling and hidden languages not displaying on language switcher. But when we turned off the W3TC cache,at least the styling for the language sites were restored. the w3tc were configured according to this wpml guidance link. the plugin currently not configured to interface with cdn provider yet. https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/
please can you suggest what we should do as the performance of the site is poor at the moment and we have to sort this issue out today?

April 10, 2019 at 6:53 pm #3580497

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

It seems that Bruno my colleague is already handling this issue in the ticket that you have opened here.
https://wpml.org/forums/topic/when-w3tc-cache-was-turned-on-it-messed-up-the-styling-and-language-switcher/
Please continue there.

In our forum, we try to keep one issue per ticket.
Continuing with one ticket per issue helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

Regards,
Itamar.

April 11, 2019 at 7:03 am #3584263

hooiC

My issue is resolved now. Thank you!