This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Bobby 4 months ago.

Assigned support staff: Bobby.

Author Posts
June 3, 2019 at 7:52 pm

Vagan Khachikyan

I am trying to: open first time directly or with cleared browser cache opening Portfolio Category page

Link to a page where the issue can be seen: hidden link

I expected to see: a text in Russian and Portfolio objects

Instead, I got: there is no items and it shows text in english in content area. After reloading page shows correctly. The same in other Portfolio category pages

June 3, 2019 at 11:05 pm #3946391

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

are you currently using any "drop-in" cache plugins ?

i was able to reproduce this issue when visiting your site, what are your results when you temporary disable your caching plugin ?

June 4, 2019 at 6:54 am #3948531

Vagan Khachikyan

Hi Bobby,

we don't use any cache plugins

June 4, 2019 at 6:27 pm #3954509

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for veryfing , there is a possibility this is being caused by a 3rd party plugin compatibility

i would like to further test this issue on our cloudways server if possible

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

June 4, 2019 at 6:41 pm #3954673

Vagan Khachikyan

Thank you, Bobby

I have already entered access information. You will find it special fields in start topic.
There is no special fields in reply text field.
Backup is done

June 5, 2019 at 1:59 am #3955959

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Unfortunately i was not able to access the backend with the details provided in the thread

i have re enabled the private fields

thank you!

June 5, 2019 at 10:14 am
June 5, 2019 at 10:15 am #3959317

Vagan Khachikyan

Please try again to access

June 6, 2019 at 5:58 am #3965933

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

i was able to take a closer look

are you using a custom theme at the moment ? and if yes how are you adding this category description to your page ?

additionally please verify that you are not using advanced-cache.php as well as other drop-in plugins that might cause caching.

if possible i would suggest contacting your host provider as well as they might have caching from their side.

June 6, 2019 at 10:03 am #3967973

Vagan Khachikyan

Yes, this is the CherryFramework Theme and it was customised.

We don't use any cache plugins.

Here you can see php settings on the hosting hidden link
There is no cache engine switched on.
It is my own VDS hosting, I have Plesk panel and root access.
All questions about hosting or access you can ask me

June 7, 2019 at 5:13 pm
June 7, 2019 at 6:07 pm #3978309

Vagan Khachikyan

In the clean theme there is no Portfolio.
And I'm not able to show how ta ad text in Portfolio category
Portfolio plugin came with Cherry Framework and Theme.
Portfolio is just a type of customised post as I know.
And we put the text like in Posts category.
You can see it on the screenshot.

June 7, 2019 at 10:11 pm #3979165

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I understand, i went forward and did some testing by installing the framework on the sandbox but it is not behaving as expected and wont show the pages well

therefore i created 2 different test categories within your site.

1. is added only within Russian categories

2. And the second one is added in English and then translated to RU

the #1 works perfect everytime , and the #2 works as explained within this ticket.

Please test them and you will notice this , but make sure that you test in an new incognito window each time.

This seems to be a compatibility issue with the portfolio plugin of the cherry framework. Unfortunately we currently do not support custom work within the forum and as this is not a commercial theme we cannot proceed with a compatibility request.

a workaround you could use would be to not link your categories in the 2 languages and just keep a set of English categories and a set of Russian categories this seems to resolve the issue

hidden link

June 7, 2019 at 10:23 pm #3979169

Vagan Khachikyan

This theme is commercial: hidden link

June 7, 2019 at 11:02 pm #3979223

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the link, the issue it self is most likely due to the cherry framework plugin (Cherry Portfolio)

i have escalated this to our compatibility developers to take a closer look and will update you once i have news

The topic ‘[Closed] Not displaying proper language in Portfolio’ is closed to new replies.