This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Im trying to copy all of our English products as polish ones however it has notr copied over the custom fields data on any of them.

Solution: I visited the site and it seems that the cause of the issue is that the ACF in the products where set to 'Copy' but not all of them. Please follow this steps: - Edit a product -> Go to the Multilingual Content Setup section -> Click on 'Show system fields' link -> Now you will see a second field not set as 'Copy' and the names starting with an underscore (_) -> Set this fields to 'Copy' -> Save the changes. - Make a small change in the information on the product -> Save the changes -> Update the translation.

Relevant Documentation:

Author Posts
May 23, 2019 at 1:07 pm #3875543

charlieH

Im trying to copy all of our English products as polish ones however it has notr copied over the custom fields data on any of them.

Is there any documentation that you are following?
I have tried following this page documentation closely but it has given me a mixzture of copied products and ones that "Need Translating".
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/
All of which have no copied acf data.

Example product in english
hidden link

polish version
hidden link

As you can see the polish one is missing the acf data.

If we provided the logins would you be able to login and see what we have potentially missed to cause the acf values not to be transferred across?
Regards
Adam

May 23, 2019 at 2:19 pm #3876575

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello Adam,
Thank you for contacting WPML support.

Before asking you to provide the credentials to access the site I kindly ask you to update all outdated plugins and themes, specially WPML plugins; flush the any cache memory that might exists and double check if the issue persists.

Note: Please don't forget to make a full backup of the site before this changes for security reasons.

Kind regards,
Carlos

May 23, 2019 at 2:42 pm #3877003

charlieH

I have done this, still no improvement.

May 23, 2019 at 2:52 pm #3877187

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Adam,
Thank you very much for your message.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

May 24, 2019 at 7:18 am #3881711

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

However you didn't share the credentials for the traffic pop-up. Please edit your previous message and add this credentials.

Regards,
Carlos

May 24, 2019 at 8:14 am #3882241

charlieH

Hi Carlos,

I have edited the message to include the details of the splash screen popup.

Also send me your email ID so we can add you as a collaborator to flywheel.

Thanks

May 24, 2019 at 10:09 am #3883331

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Adam,
Thank you for sharing this new credentials.

I visited the site and it seems that the cause of the issue is that the ACF in the products where set to 'Copy' but not all of them. Please follow this steps:
- Edit a product -> Go to the Multilingual Content Setup section -> Click on 'Show system fields' link -> Now you will see a second field not set as 'Copy' and the names starting with an underscore (_) -> Set this fields to 'Copy' -> Save the changes.
- Make a small change in the information on the product -> Save the changes -> Update the translation.

Could you tell me the result of the steps above?

Regards,
Carlos

May 24, 2019 at 10:26 am #3883497

charlieH

HI thanks for this. I followed your steps and carried out these changes on this test product but the content on the Polish version still isn't pulling through if you check the links:

hidden link
hidden link

Let me know what you might suggest next?

May 24, 2019 at 1:05 pm #3884989

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Please follow this steps:
- Edit the product hidden link -> Click on the translation icon -> In the translation of the product click on 'Overwrite with English content' button within the Languages block in the right column -> Save the changes.

Does the issue persists?

Note: I suspect that this issue is happening because you set the Products to appear in the secondary language even if there is no translation (WPML -> Settings -> Post Type Translation) and then you started to translate this product. If you create a new product and don't translate it you should get the product in English in both languages in the frontend and showing all the custom fields.

Regards,
Carlos

May 24, 2019 at 1:22 pm #3885193

charlieH

Hi Carlos,

I can't find the button 'Overwrite with English content'. See attached screenshots... Let me know thoughts.

Is there a way that you could make ALL products on the Polish area show all English text? This is what we are trying to achieve. If we have to edit the settings for each product individually then we will have to do this across 501 products which is going to take a long time. So is there a quicker way to apply across all products?

May 24, 2019 at 3:12 pm #3885979

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Could you tell me if you desire to have products in Polish with English content? or you desire to create products in English and be shown automatically en Polish too?

Regards,
Carlos

May 24, 2019 at 3:19 pm #3885997

charlieH

We want to keep all the products we currently have on the English site and copy them across so they appear on the Polish site too (Still in English language).

May 24, 2019 at 4:30 pm #3886355

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

In this case there is an option that you are using already, which is in WPML -> Settings -> Post Type Translation -> Setting the products to the option in the middle that let's you show the products in the secondary language if there isn't a translation.

With this option you only need to create the products in English and they will be shown in both languages, so there is no need to do any translation.

Please create a product in English -> Add all the information on the custom fields and save the changes. Could you see this product and the custom fields in Polish too?

Regards,
Carlos

May 24, 2019 at 4:45 pm #3886403

charlieH

Ok so we have that middle option selected already for 'Post Type Translation'.

I then tested adding a new product in english and then it appears correctly on the Polish site which is great!! This is the test product. hidden link

What I now need to do is to do the same will all the existing products on the website. Can you let me know how we can apply this rule? If possible can you do this for me?

Example:
This english product hidden link when you view it in Polish doesn't display any info further down the page. It should show the same info as on the English site.

May 27, 2019 at 6:58 am #3893869

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

For existing products you need to follow this steps:
- Go to Products -> Delete the ones in Polish -> Make sure you remove them from the trash too.
- Bulk Edit the products in English -> Click the Save button without making any changes.

Note: Please create a full backup of the site before making any change.

Regards,
Carlos