This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Yvette 1 year, 5 months ago.

Assigned support staff: Yvette.

Author Posts
March 6, 2018 at 12:37 pm

danielleC-2

I am trying to: Access my WP Dashboard

Link to a page where the issue can be seen: -

I expected to see: My Dashboard

Instead, I got: Not enough permissions to access this page

Hi. I'm having a though time here.

I found out that when I activate WPML Multilingual CMS, I'm instantly logged out from my WP, and when I try to access again, it says I have not enough permissions to access this page. I simply can't login.... Then I need to rename my Plugins folder to plugins2, login on WP, rename back the plugins folder again so I can disable all my plugins. It's the only way I can login again. So I made a test enabling one by one... and started with WPML. WPML Multilingual CMS is the one which is giving the error.
I've suspected on WPML because I looked on my PHPMyAdmin > wp_usermeta > wp_capabilities to try to find a solution and saw a lot of WMPL info there...

a:17:{s:34:"wpml_manage_translation_management";b:1;s:21:"wpml_manage_languages";b:1;s:41:"wpml_manage_theme_and_plugin_localization";b:1;s:19:"wpml_manage_support";b:1;s:36:"wpml_manage_woocommerce_multilingual";b:1;s:37:"wpml_operate_woocommerce_multilingual";b:1;s:29:"wpml_manage_media_translation";b:1;s:22:"wpml_manage_navigation";b:1;s:24:"wpml_manage_sticky_links";b:1;s:30:"wpml_manage_string_translation";b:1;s:33:"wpml_manage_translation_analytics";b:1;s:25:"wpml_manage_wp_menus_sync";b:1;s:32:"wpml_manage_taxonomy_translation";b:1;s:27:"wpml_manage_troubleshooting";b:1;s:31:"wpml_manage_translation_options";b:1;s:13:"administrator";b:1;s:9:"translate";b:1;}

So I decided to disable the plugins to see if the problem was solved....

Can someone please help me?

Thanks in advance.

March 6, 2018 at 5:37 pm #1538025

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello there,

Welcome to WPML support forum.

This is a known issue. Our developers are trying to fix it.

While waiting that one of my teammates takes care of your case, can you please try one of the following workarounds?

1. Disable Memcached

2. Use PHP 5.6.x instead of PHP 7

Let us know if it helps.

March 7, 2018 at 12:26 am #1538420

danielleC-2

Yes, it helped.
I was already using PHP 5.6... but I've disabled all the caches... including cloudflare...
Can you let me know when the update for this problem would be available?
I'd prefer using the cache plugins I'm used to.

Thanks.

March 7, 2018 at 8:15 am #1538624

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

We have added this forum thread to the list of clients that should be informed of any fixes or notices regarding this issue.

Before we escalate this ticket, could you please tell us a bit more about your installation:

1. Are you using a SiteGround installation?

2. Technical Information on you environment
Could you please provide information about your environment by following thsese steps: http://wpml.org/faq/provide-debug-information-faster-support/

This additional information will help us in finding a solution quicker.
Thanks

March 7, 2018 at 7:22 pm #1539673

danielleC-2

Yes, I'm using SiteGround.

March 7, 2018 at 10:49 pm #1539869

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thank you for that detail.

Your ticket has now been escalated to our 2nd tier team.

March 8, 2018 at 7:27 pm #1541089

danielleC-2

I need help with one more thing...
Yesterday my site was working normally (without the SiteGround Cache settings, using only Cloudflare). Now I can't load hidden link (my WooCommerce Products List) when I enable WPML plugins. It shows this error:
hidden link

When I disable the plugins I can see all the list of products:
hidden link

I've already disabled CloudFlare, but it's not working...

As I work with a virtual store I cant let WPML disabled... Can you solve this problem?
I need to include products with urgency..

March 9, 2018 at 2:30 pm #1541872

danielleC-2

Now I just noticed my shopping cart page is crashing when the plugin is enabled... it's showing the following..

500 - Internal Server Error
This is a temporary server error.
Please try to reload the webpage later.

Everyday is a new crash... Are you changing something there? When is it gonna be fixed? I can't let my shop all messed up.

March 28, 2018 at 4:17 pm #1559264

danielleC-2

When are you going to answer me on this?????????????????

May 10, 2018 at 8:28 am #2067460

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´m so sorry that this ticket was overlooked on my inbox.

The problem was reported to SiteGround and we have confirmation that a fix was merged with their master code.
hidden link

This should resolve your initial issue.

For the other issues, once your ticket is escalated, it is removed from my normal work queue inbox so I will not be notified if you put other questions/responses here as I would in the normal forum. I will be notified if the related internal workflow has a resolution.

If you have a new issue, it is always required to open a new forum thread which I suppose you eventually did.